Bug 6099 - Upgrade XML jars and bouncycastle in 4.0.x
: Upgrade XML jars and bouncycastle in 4.0.x
Status: RESOLVED FIXED
: Java WS Core
globus_wsrf_core
: 4.0.7
: Macintosh All
: P3 normal
: 4.0.8
Assigned To:
: http://www.globus.org/mail_archive/jw...
:
:
: 6218
  Show dependency treegraph
 
Reported: 2008-05-22 10:57 by
Modified: 2008-08-11 10:56 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-05-22 10:57:07
http://dev.globus.org/wiki/GridShib_for_GT_Packaging

Gridshib for GT updates four jars: xalan.jar, xercesImpl.jar,
xml-apis.jar,jce-jdk13-125.jar

In all four cases, the update from our 4.0.x version to our (pending) 4.2.0
versions.  This is gross, because they're modifying files that are owned by
Java WS Core.  Applying update packages of core could break GS4GT installations
because it would revert those four jar files.  This is newly important because
TeraGrid's gateway group will be distributing GS4GT, which will affect TG's
ability to update core without breaking the gateway.

So, please evaluate whether this upgrade is safe.  If it is safe, please update
before the next update release of core or GT4.0.8, whichever comes first.
------- Comment #1 From 2008-06-16 19:19:06 -------
The dependency on jce-jdk13-131.jar has been removed.  Both GridShib SAML Tools
and GridShib for GT are in the process of being downgraded to
jce-jdk13-125.jar.
------- Comment #2 From 2008-07-09 16:38:17 -------
Updated xerces to 2.7.1, xalan to 2.6 and corresponding xml-apis.jar. All jars
copied from GT 4.2.0 release and endorsed directory set up with new jars.
------- Comment #3 From 2008-07-18 11:20:34 -------
(In reply to comment #0)
> 
> Gridshib for GT updates four jars: xalan.jar, xercesImpl.jar,
> xml-apis.jar,jce-jdk13-125.jar

For the record, all of these dependencies will be removed in GS4GTv0.6.1.  See
Bug 6168 and Bug 6218 for details.
------- Comment #4 From 2008-08-09 11:38:50 -------
XercesImpl-2.7.1.jar and xml-apis.jar are missing from the endorsed directory
in the GT 4.0.8 distribution.
------- Comment #5 From 2008-08-11 10:06:16 -------
Thanks Tom. 

Confirmed issue, created a new bug to track advisory and documentation better:
http://bugzilla.globus.org/bugzilla/show_bug.cgi?id=6296.
------- Comment #6 From 2008-08-11 10:56:43 -------
Fxied: http://bugzilla.globus.org/bugzilla/show_bug.cgi?id=6296#c1.