Bug 5778 - GRAM2 audting: no error message on db update failure
: GRAM2 audting: no error message on db update failure
Status: RESOLVED DUPLICATE of bug 6400
: GRAM
general
: 4.0.5
: Open Science Grid (OSG) Linux
: P3 blocker
: 4.0.7
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2008-01-11 14:59 by
Modified: 2009-03-19 09:48 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-01-11 14:59:57
Database: MySql 4.1.22

In GRAM4, when the database is not accessible, the audit logs never indicate
that a failure has occured.  They look exactly the same as when successful.

I verified this under 2 conditions:
 1. when the connection timeout occurred as described in
    <a href="http://bugzilla.globus.org/bugzilla/show_bug.cgi?id=5777">Bug
5777</a>
 2. when I deliberately changed the password for the database in the
    $GLOBUS_LOCATION//etc/gram-service/jndi-config.xml file to an invalid one.

An ERROR/SEVERE log message should be generated when this occurs.

I would like to note that this is also related to <a
href:"http://bugzilla.globus.org/globus/show_bug.cgi?id=5713">Bug 5713</a>.
------- Comment #1 From 2009-03-19 09:48:57 -------

*** This bug has been marked as a duplicate of bug 6400 ***