Bug 5677 - Thread blocking occurs when recovering the scheduler
: Thread blocking occurs when recovering the scheduler
Status: CLOSED FIXED
: Gridway
Core
: unspecified
: All All
: P3 normal
: 5.4
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2007-11-14 05:37 by
Modified: 2008-04-01 09:45 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-11-14 05:37:49
When the scheduler dies, there is a race condition that can result in gridway
getting blocked. It is non trivial to reproduce, since it happens when the DM
is recovering the jobs and sending them to the scheduler, and also from other
thread the core requests to schedule another job. The solution would be to stop
the scheduling until the recovering is done.
------- Comment #1 From 2007-12-11 04:45:37 -------
Changes in TRUNK & gw_5_2_branch