Bug 5624 - LIGO: globus-rls-admin and globus-rls-cli tools do not exit properly on Debian 4.0 ONLY (Workaround)
: LIGO: globus-rls-admin and globus-rls-cli tools do not exit properly on Debia...
Status: RESOLVED FIXED
: Replica Location
RLS
: development
: PC Linux
: P3 normal
: ---
Assigned To:
:
:
: 5481
:
  Show dependency treegraph
 
Reported: 2007-10-19 09:15 by
Modified: 2008-05-28 19:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-10-19 09:15:55
The system has these details:

datarobot@golf:~$ uname -a
Linux golf 2.6.18-5-686 #1 SMP Wed Sep 26 17:54:59 UTC 2007 i686 GNU/Linux
datarobot@golf:~$ cat /etc/issue
Debian GNU/Linux 4.0 \n \l

datarobot@golf:~$ gcc --version
gcc (GCC) 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

The version of RLS used is that from the GT 4.0.5 source tarball. That is, RLS
and the globus-rls-admin tool were built from source on the machine using the
gcc shown above.

When the globus-rls-admin command is run it hangs after printing out the
expected output. For example:

datarobot@golf:~$ globus-rls-admin -S rls://localhost
Version:    4.3
Uptime:     168:38:10
LRC stats
  update method: lfnlist
  update method: bloomfilter
  lfnlist update interval: 86400
  bloomfilter update interval: 900
  numlfn: 0
  numpfn: 0
  nummap: 0
RLI stats
  updated via bloomfilters

At this point the command hangs and control is not returned back to the shell.
Neither Ctrl+c nor Ctrl+z interrupt the process and return command to the
shell.

This behavior is not specific to the '-S' flag. It also happens when using the
'-p' flag to ping the server. It may happen with other options too but we have
not tested all of them.

I will run the command under strace and attach the output to the bug report.
------- Comment #1 From 2007-10-19 09:19:45 -------
The output of running the hanging command under strace is at

http://www.lsc-group.phys.uwm.edu/lscdatagrid/downloads/ldr_software/strace.out
------- Comment #2 From 2007-10-19 12:53:42 -------
Can you point g-r-a at another server on another host and see what happens?
Preferably, this would be a server on a host you're not having problems with.
It may also be worth testing with an older server if you have one running.
------- Comment #3 From 2007-10-19 13:51:07 -------
On the Debian 4 system golf.astro.cf.ac.uk I ran 

globus-rls-admin -S rls://nemo-dataserver.phys.uwm.edu

and saw the same behavior. The expected output is written to the terminal but
then 
control is not returned to the shell.

The RLS running on the system nemo-dataserver.phys.uwm.edu reports version 4.2.
------- Comment #4 From 2007-10-22 17:39:22 -------
The same problem occurred with a USC user using a Debbian 4 release:

Linux version 2.6.18-4-686 (Debian 2.6.18.dfsg.1-12etch2) (dannf@debian.org)
(gc
c version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)) #1 SMP Wed May 9
23:03:
12 UTC 2007

I have tried out the g-r-a and g-r-c clients on some Debbian 3.1 boxes and it
works fine. No probems on RH8, RH9, FC6, and Solaris (SunOS 5.9) that I can
tell.
------- Comment #5 From 2007-10-23 07:21:38 -------
I ran globus-rls-admin under gdb and saw that the third (3rd) time after
executing the command

globus_module_deactivate(modules[i]);

is when the client hangs. So it appears that it is hanging when deactivating
the GLOBUS_RLS_CLIENT_MODULE.
------- Comment #6 From 2007-10-23 07:41:18 -------
I commented out the code in admin.c that loops over globus_module_deactivate
and forced a rebuild and now the client does not hang. 

I also tried changing to using globus_module_deactivate_all() but that did not
help and the client continued to hang.
------- Comment #7 From 2007-10-23 07:57:23 -------
I see that the deactivation loop counts down/backwards, so the client is
actually hanging during the GLOBUS_COMMON_MODULE deactivation.
------- Comment #8 From 2007-10-23 08:12:53 -------
So this is bug 5481.
------- Comment #9 From 2007-11-05 14:06:35 -------
Since there is a Debian 4.0 workaround, I'm going to change severity to normal.
Hopefully that seems reasonable, given the circumstances.
------- Comment #10 From 2007-11-19 13:09:07 -------
I'm going to close this since the "fix" is a workaround for a Debian 4.0 bug
that is out of our control.
------- Comment #11 From 2007-12-12 11:56:31 -------
After reopening this bug I'm closing it with FIXED status because the core libs
have fixed the bug (see bug 5481).