Bug 5481 - Callback deactivation hang on Debian 4.0 w/pthreads
: Callback deactivation hang on Debian 4.0 w/pthreads
Status: RESOLVED FIXED
: Toolkit Internals
globus_common
: unspecified
: PC Linux
: P3 normal
: 4.0.6
Assigned To:
:
:
:
: 5624
  Show dependency treegraph
 
Reported: 2007-08-17 07:28 by
Modified: 2007-12-11 12:40 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-08-17 07:28:20
Deactivating the callback module in c common hangs on Debian 4.0 when built
with phreads. I did a bunch of tracing and debugging on this, and think it
relates to this libc bug:
http://www.mail-archive.com/debian-glibc@lists.debian.org/msg33956.html. 

I've observed that the hang occurs when destroying the condition variable that
the callback signal thread was waiting on. It appears that pthread_cancel is
corrupting the condition variable being waited on. The broadcast-after-cancel
in the common lib makes the condition destroy not fail with EBUSY, but it still
hangs.
------- Comment #1 From 2007-08-17 15:41:04 -------
Is this trunk, branch, or both?
------- Comment #2 From 2007-10-09 11:49:35 -------
The trick of using LD_ASSUME_KERNEL=2.4.19 suggested on
http://www.mail-archive.com/debian-glibc@lists.debian.org/msg33956.html
works.
The fix for the debian bug related, will not be backported to stable.
I think that bugs 5581 is a duplicate of this.
------- Comment #3 From 2007-12-11 12:31:37 -------
Fix for this is committed to 4.0 branch and trunk. The LD_ASSUME_KERNEL
workaround had some side effects.

Joe