Bug 5251 - WS IM_MAD launches one java process per host for monitoring
: WS IM_MAD launches one java process per host for monitoring
Status: CLOSED FIXED
: Gridway
Middleware Access Drivers
: 5.2
: All All
: P3 normal
: 5.2.3
Assigned To:
:
:
: 5320
:
  Show dependency treegraph
 
Reported: 2007-04-27 10:15 by
Modified: 2007-10-10 03:41 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-04-27 10:15:01
When the number of hosts exceeds a threshold (being set by the GridWay server
specs), the number of java process overloads the GridWay Server.

One possible solution would be to implement a mechanism to group this
monitoring processes (say, 5 in a row) instead of launching all of them
simultaneously.
------- Comment #1 From 2007-04-27 11:09:54 -------
This bug has been reported by the AstroGrid-D workgroup.
------- Comment #2 From 2007-05-16 06:28:03 -------
*** Bug 5303 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2007-05-25 07:55:34 -------
Solved in a new CAMPAIGN (bug 5303).
------- Comment #4 From 2007-10-04 11:23:53 -------
A new IM MAD should be developed using a single (multi-threaded) Java process
to mitigate JVM start issues.
------- Comment #5 From 2007-10-05 11:26:52 -------
Changes (by Tino) are in the trunk.