Bug 5146 - RFT Postgres schema issues
: RFT Postgres schema issues
Status: RESOLVED FIXED
: RFT
RFT
: 4.0.3
: PC Linux
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2007-03-23 11:18 by
Modified: 2007-03-23 17:04 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-03-23 11:18:30
While trying to transfer files using rft with GT4.0.3, I encounter the
following error with the 'rft' command line client

[jini@***** ~]$ rft -h *****.ps.univa.com -f /tmp/transfer.xfr
Number of transfers in this request: 1
Subscribed for overall status
Termination time to set: 60 minutes

 Overall status of transfer:
Finished/Active/Failed/Retrying/Pending
0/1/0/0/0
Error:Error updating permissions of a file:
 /etc/group [Caused by: RFT database update error [Caused by: ERROR: column
"permissions" is of type integer but expression is of type character varying]]

 Overall status of transfer:
Finished/Active/Failed/Retrying/Pending
0/0/1/0/0
Error:Error updating permissions of a file:
 /etc/group [Caused by: RFT database update error [Caused by: ERROR: column
"permissions" is of type integer but expression is of type character varying]]
All Transfers failed !

Contents of /tmp/transfer.xfr are:
[jini@***** ~]$ cat /tmp/transfer.xfr
true
16000
16000
false
1
true
1
null
null
false
10
gsiftp://*****.ps.univa.com:2811/etc/group
gsiftp://********.univa.com:2811/tmp/rftTest_Done.tmp

[globus@***** ~]$ postgres --version
postgres (PostgreSQL) 8.0.8

Also, if I change the field "permissions" that is the error above, to a 'text'
field rather than an 'int' field, the rft transfer works fine after dropping
the existing database, creating it again and using the new schema file.

[globus@***** ~]$ diff
/usr/local/globus-4.0.3/share/globus_wsrf_rft/rft_schema.sql
/usr/local/globus-4.0.3/share/globus_wsrf_rft/rft_schema_modified.sql
63c63
<     permissions         int,
---
>     permissions         text,

[jini@***** ~]$ rft -h *****.ps.univa.com -f /tmp/transfer.xfr
Number of transfers in this request: 1
Subscribed for overall status
Termination time to set: 60 minutes

 Overall status of transfer:
Finished/Active/Failed/Retrying/Pending
0/1/0/0/0

 Overall status of transfer:
Finished/Active/Failed/Retrying/Pending
1/0/0/0/0
All Transfers are completed

[jini@******** ~]$ ll /tmp/rftTest_Done.tmp
-rw-r--r--  1 jini jini 779 Mar 23 11:12 /tmp/rftTest_Done.tmp

We have noted the same behaviour in postgres version 8.1.4, 8.1.8 and I have
also seen this behaviour in postgres version 7.4.16
------- Comment #1 From 2007-03-23 17:04:11 -------
Fix is committed to release branch. Thanks for the contrib.