Bug 5112 - submitting job error
: submitting job error
Status: RESOLVED INVALID
: GRAM
wsrf managed job factory service
: 4.0.3
: PC Linux
: P3 enhancement
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2007-03-20 08:49 by
Modified: 2008-05-27 12:00 (History)


Attachments
file system mapping (3.72 KB, application/xml)
2007-03-22 11:03, Martin Feller
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-03-20 08:49:04
when i submitted job without PBS,Submitting job was okay ,as following below
[bh@gram2 lib]$ globusrun-ws -submit -c /bin/date
Submitting job...Done.
Job ID: uuid:28724aa6-d625-11db-93ba-00306e2290f3
Termination time: 03/20/2007 14:21 GMT
Current job state: Active
Current job state: CleanUp
Current job state: Done

but when i subitted job with PBS ,error as following below
Delegating user credentials...Failed.
globusrun-ws: Error trying to delegate
Error querying delegation factories
globus_soap_message_module: SOAP Fault
Fault code: soapenv:Server.generalException

after that,i found the problem is the mapping between GRAM and FTP hosts .
and i modified 'globus_gram_fs_map_config.xml' as below

</ns1:map><ns1:map
xmlns:ns1="http://www.globus.org/namespaces/2004/10/gram/job"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:type="ns1:FileSystemMapType">
 <ns1:scheduler xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xsi:type="xsd:string">PBS</ns1:scheduler>
 <ns1:ftpServer xsi:type="ns1:FtpServerType">
  <ns1:protocol xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xsi:type="xsd:string">gsiftp</ns1:protocol>
  <ns1:host xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xsi:type="xsd:string">gram2.shu.edu.cn</ns1:host>
  <ns1:port xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xsi:type="xsd:unsignedShort">2811</ns1:port>
 </ns1:ftpServer>
 <ns1:mapping xsi:type="ns1:FileSystemPathMappingType">
  <ns1:jobPath xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xsi:type="xsd:string">/home/bh</ns1:jobPath>
  <ns1:ftpPath xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xsi:type="xsd:string">/home/bh</ns1:ftpPath>
 </ns1:mapping>

nodes: a.rsl lies in /home/bh
but still failed as above ,would you pleased be so kind as to tell me how to
modified that xml file
------- Comment #1 From 2007-03-20 10:03:43 -------
I think you mix up things here a bit. Can we go step by step?

1. If you submit a simple job to PBS like you mention below
   ("globusrun-ws -submit -c /bin/date") you really should not run into the
   delegation issues because no credentials are delegated in simple jobs.
   Could you confirm that you really get that delegation problem when you use
   the above submission command but with PBS. It should look like
   "globusrun-ws -submit -Ft PBS -c /bin/date"

2. Please add the command and the job description you use when you get the
   errors below.

3. As far as i know this error is not related to globus_gram_fs_map_config.xml
   but you're right: you need to have a mapping for PBS in that file.
------- Comment #2 From 2007-03-20 20:47:48 -------
(In reply to comment #0)
> when i submitted job without PBS,Submitting job was okay ,as following below
> [bh@gram2 lib]$ globusrun-ws -submit -c /bin/date
> Submitting job...Done.
> Job ID: uuid:28724aa6-d625-11db-93ba-00306e2290f3
> Termination time: 03/20/2007 14:21 GMT
> Current job state: Active
> Current job state: CleanUp
> Current job state: Done
> but when i subitted job with PBS ,error as following below
> Delegating user credentials...Failed.
> globusrun-ws: Error trying to delegate
> Error querying delegation factories
> globus_soap_message_module: SOAP Fault
> Fault code: soapenv:Server.generalException
> after that,i found the problem is the mapping between GRAM and FTP hosts .
> and i modified 'globus_gram_fs_map_config.xml' as below
> </ns1:map><ns1:map
> xmlns:ns1="http://www.globus.org/namespaces/2004/10/gram/job"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xsi:type="ns1:FileSystemMapType">
>  <ns1:scheduler xmlns:xsd="http://www.w3.org/2001/XMLSchema"
> xsi:type="xsd:string">PBS</ns1:scheduler>
>  <ns1:ftpServer xsi:type="ns1:FtpServerType">
>   <ns1:protocol xmlns:xsd="http://www.w3.org/2001/XMLSchema"
> xsi:type="xsd:string">gsiftp</ns1:protocol>
>   <ns1:host xmlns:xsd="http://www.w3.org/2001/XMLSchema"
> xsi:type="xsd:string">gram2.shu.edu.cn</ns1:host>
>   <ns1:port xmlns:xsd="http://www.w3.org/2001/XMLSchema"
> xsi:type="xsd:unsignedShort">2811</ns1:port>
>  </ns1:ftpServer>
>  <ns1:mapping xsi:type="ns1:FileSystemPathMappingType">
>   <ns1:jobPath xmlns:xsd="http://www.w3.org/2001/XMLSchema"
> xsi:type="xsd:string">/home/bh</ns1:jobPath>
>   <ns1:ftpPath xmlns:xsd="http://www.w3.org/2001/XMLSchema"
> xsi:type="xsd:string">/home/bh</ns1:ftpPath>
>  </ns1:mapping>
> nodes: a.rsl lies in /home/bh
> but still failed as above ,would you pleased be so kind as to tell me how to
> modified that xml file

(In reply to comment #1)
> I think you mix up things here a bit. Can we go step by step?
> 1. If you submit a simple job to PBS like you mention below
>    ("globusrun-ws -submit -c /bin/date") you really should not run into the
>    delegation issues because no credentials are delegated in simple jobs.
>    Could you confirm that you really get that delegation problem when you use
>    the above submission command but with PBS. It should look like
>    "globusrun-ws -submit -Ft PBS -c /bin/date"
> 2. Please add the command and the job description you use when you get the
>    errors below.
> 3. As far as i know this error is not related to globus_gram_fs_map_config.xml
>    but you're right: you need to have a mapping for PBS in that file.

thanks for your answers,i got that delegation problem when i submitted job to
PBS with the command :
globusrun-ws -submit -Ft PBS -c /bin/date,i know i need a mapping for PBS,but i
don't know how to
modified that xml file,would you please be so kind  to tell me how to
modified that xml file?
------- Comment #3 From 2007-03-22 11:02:37 -------
I'm still sure that you don't run into this problem if you submit the job using
"globusrun-ws -submit -Ft PBS -c /bin/date", because no delegation takes place
there at all. I removed all my file system mappings, executed that job, but
could
not reproduce your error.
Are you sure that you don't use the "-s" option for output streaming?
I'll attach my file system mappings, adapt settings like host and port as
needed.
------- Comment #4 From 2007-03-22 11:03:58 -------
Created an attachment (id=1216) [details]
file system mapping

my file system mappings. Take what you need from that file
------- Comment #5 From 2007-03-23 02:17:48 -------
hi
u r great!!! your file mapping did work after i modified it with my hostname
but still a little bug :

[bh@gram2 ~]$ globusrun-ws -submit -Ft PBS -s -c 1.rsl
Delegating user credentials...Done.
Submitting job...Done.
Job ID: uuid:74604890-d900-11db-98b2-00306e2290f3
Termination time: 03/24/2007 05:36 GMT
Current job state: Pending
Current job state: Active
connect to address 10.128.0.247: Connection refused
connect to address 10.128.0.247: Connection refused
trying normal rsh (/usr/bin/rsh)
gram2.shu.edu.cn: Connection refused
/var/spool/PBS/mom_priv/jobs/7.gram2.shu.SC: line 55: [: too many arguments
Current job state: CleanUp-Hold
Current job state: CleanUp
Current job state: Done
Destroying job...Done.
Cleaning up any delegated credentials...Done.

my hostname and ip are okay ,but why connection refused? i'm looking ur reply
many thanks
------- Comment #6 From 2008-02-06 13:23:45 -------
These types of problems are typically not bugs.  For help on these issues send
email to gram-user@globus.org.  Info about subscribing to the gram lists is
here:
http://dev.globus.org/wiki/GRAM#Mailing_Lists
------- Comment #7 From 2008-05-26 04:11:25 -------
(In reply to comment #4)
> Created an attachment (id=1216) [edit] [details]
> file system mapping
> my file system mappings. Take what you need from that file

Hello
I have the same problem
Could you please post here the data of this attachment
http://bugzilla.mcs.anl.gov/globus/attachment.cgi?id=1216
I cannot view as this file was disabled due to some problems connected with
spam
------- Comment #8 From 2008-05-27 12:00:51 -------
Sent via e-mail