Bug 5091 - Incomplete jobmanager contact string crashes gram client
: Incomplete jobmanager contact string crashes gram client
Status: RESOLVED FIXED
: GRAM
gt2 Gram client
: 4.0.3
: All All
: P3 normal
: 4.0.5
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2007-03-12 11:16 by
Modified: 2007-03-15 12:18 (History)


Attachments
Patch to GRAM Client / Protocol libraries (3.19 KB, patch)
2007-03-12 15:09, Joe Bester
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-03-12 11:16:09
If you call a gram client library function with a jobmanager contact string
that doesn't have a path, the library segfaults. The problem is in
globus_gram_protocol_frame_request(), which assumes that if globus_url_parse()
returns GLOBUS_SUCCESS, then globus_url_t.url_path will be non-NULL. That's not
true for URLs like https://gate02.grid.umich.edu:40041.

You can reproduce this using globusrun:

globusrun -status https://foo.edu:40041

This problem is currently affecting Condor-G. A rare bug in Condor-G causes
some jobmanager contact strings to be truncated. When this bug occurs, the gram
bug described here exacerbates the problem. We are working on finding the
Condor-G bug, but it's tricky to track down.
------- Comment #1 From 2007-03-12 15:09:01 -------
Created an attachment (id=1206) [details]
Patch to GRAM Client / Protocol libraries

Attaching a patch which avoids the crash and returns an invalid contact error
when the contact URL does not contain a path.

joe
------- Comment #2 From 2007-03-15 11:52:07 -------
I applied the patch and the crashes ceased. Now, the functions return gram
error 80 as expected.
------- Comment #3 From 2007-03-15 12:18:59 -------
Fix applied to 4.0 branch and trunk.