Bug 5032 - Staging information removed from the perl description.
: Staging information removed from the perl description.
Status: CLOSED FIXED
: GRAM
wsrf managed execution job service
: unspecified
: Macintosh All
: P3 normal
: 4.0.6
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2007-02-26 10:15 by
Modified: 2008-01-07 11:04 (History)


Attachments
Proposed patch for passing staging information to the perl job description (3.16 KB, patch)
2007-03-06 05:55, Tino Vázquez
Details
job that causes patched code to fail (1.30 KB, application/xml)
2007-03-13 11:22, Martin Feller
Details
[Second Version] Proposed patch for passing staging information to the perl job description (3.08 KB, patch)
2007-03-27 08:09, Tino Vázquez
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-02-26 10:15:28
Due to legacy code from pre-WS, WS-GRAM
java classes strips the stage-in and stage-out information from the perl
job description (transfers are managed differently, RFT is used for
WS-GRAM and globus-url-copy for pre-WS). Therefore, GridGateWay needs either
special extensions in the rsl job description (which it currently
supports) or to patch globus in order to treat correctly the file
staging. What we do is to rename (instead of removing) the filestagein
and filestageout attributes in the perl job description to gwfilestagein
and gwfilestageout respectively.

Do you feel like you could accommodate this change? We need the staging
information in order to transfer files forward to the grid encapsulated
in GRAM by GridWay.
------- Comment #1 From 2007-03-06 05:55:09 -------
Created an attachment (id=1201) [details]
Proposed patch for passing staging information to the perl job description

This patch is for ws-gram tagged with globus_4_0_branch.
------- Comment #2 From 2007-03-13 11:19:45 -------
I applied your patch to a 4.0.5 alpha version. PerlJobDescription.java didn't
change, so no problems from this side.
But the changes you did don't work as soon as more than one transfer is
specified inside of fileStageIn (and probably fileStageOut too). The job
fails and I get the following error message on the client side:

Script stderr:
Bareword found where operator expected at
/opt/GT_4.0.5_alpha/tmp/gram_job_mgr3668.tmp line 4, near
"'gsiftp://osg-test1.unl.edu:2811/tmp/myEcho,    filestagein => [ 'gsiftp"
(Missing operator before gsiftp?)Bad name after myEcho2' at
/opt/GT_4.0.5_alpha/tmp/gram_job_mgr3668.tmp line 4.Compilation failed in
require at /opt/GT_4.0.5_alpha/lib/perl/Globus/GRAM/JobDescription.pm line 93.

I'll attach my job description for your information.

I'm not really sure what the problem is, but it looks a bit strange to me
that you want to create the same variable name for each transfer (filestagein)
in your patch:

for(int i =0 ; i < xfertype.length; i++)
{
    String destURL= xfertype[i].getDestinationUrl();
    description.append("    filestagein => [ '"
    +destURL+",");
}

Due to these problems we'll not be able to add it to 4.0.5. But if you provide
a new patch we can add it later. 
------- Comment #3 From 2007-03-13 11:22:20 -------
Created an attachment (id=1208) [details]
job that causes patched code to fail
------- Comment #4 From 2007-03-27 08:09:55 -------
Created an attachment (id=1223) [details]
[Second Version] Proposed patch for passing staging information to the perl job
description

Ok, my apologies, my fault entirely. This one works well with the rsl that
wasn't working before.
------- Comment #5 From 2007-06-22 18:10:16 -------
I don't think this got into 4.0.5.  We'll have to add this for 4.0.6
------- Comment #6 From 2007-06-22 19:23:29 -------
oh right, somehow this was buried in oblivion. tino, you should have
reminded us more here. but 4.0.6 will be fine (if we don't forget it
again ;-) )
------- Comment #7 From 2008-01-07 11:04:09 -------
Just applied the patched. Did some minor formatting changes.
Will close this bug
------- Comment #8 From 2008-01-07 11:04:46 -------
Just applied the patched. Did some minor formatting changes.
Will close this bug