Bug 4918 - user account details are cached even for unknown users
: user account details are cached even for unknown users
Status: RESOLVED WONTFIX
: GRAM
wsrf managed execution job service
: 4.0.3
: Macintosh All
: P3 minor
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2006-12-18 04:54 by
Modified: 2012-09-05 11:43 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-12-18 04:54:12
I'm not sure this is the cause, but it would fit the problem I have seen.

I installed GT4 on a clean system and ran a echo hello world job to verify the
installation. However, I had forgot to add the target account specified in the
gridmap.

After adding the account I was able to submit /bin/true jobs fine, but output
staging did not work, I got the following error:
globusrun-ws: Job failed: Invalid permissions on stdout /994d15e66...0.stdout

Note that the "home" path component was zero. Restarting the container makes
the problem go away, which makes me believe that GRAM is caching user entries
even for failed lookups, which seems odd.
------- Comment #1 From 2007-09-19 11:38:08 -------
Reassigning to current GRAM developer to close/fix as appropriate.
------- Comment #2 From 2012-09-05 11:43:33 -------
Doing some bugzilla cleanup...  Resolving old GRAM3 and GRAM4 issues that are
no longer relevant since we've moved on to GRAM5.  Also, we're now tracking
issue in jira.  Any new issues should be added here:

http://jira.globus.org/secure/VersionBoard.jspa?selectedProjectId=10363