Bug 4905 - setup-globus-gram-job-manager.pl fails silently when globus-version is missing
: setup-globus-gram-job-manager.pl fails silently when globus-version is missing
Status: RESOLVED FIXED
: GRAM
gt2 Gatekeeper/Jobmanager
: development
: Macintosh All
: P3 normal
: 4.0.6
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2006-12-14 09:44 by
Modified: 2007-08-07 11:34 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-12-14 09:44:09
-globus-toolkit-version <version> was added as part of the auditing work.  It
is a field in the audit record.  At post install time, the program
setup-globus-gram-job-manager.pl sets the JM .conf file with this arg.  The
value to that argument comes from running 'globus-version'.  Currently, if
globus-version does not succeed, it is undetected causing the JM.conf file to
be corrupted and the service unusable.  The setup script should ensure that
running globus-version is successful and if not produce a fatal error that
stops the build.
------- Comment #1 From 2007-08-07 11:34:28 -------
Patched the script to set the version to unknown if globus-version does not
succeed. Seems like a relatively unlikely situation and since few people will
use the auditing, erroring out is probably not needed.