Bug 4790 - stdout RP gets null
: stdout RP gets null
Status: RESOLVED FIXED
: GRAM
wsrf managed execution job service
: 4.0.3
: PC Linux
: P3 major
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2006-10-18 17:16 by
Modified: 2008-02-05 15:24 (History)


Attachments
Gemlca log showing null RP (18.51 KB, text/plain)
2006-10-18 17:23, Thierry Delaitre
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-10-18 17:16:44
Hello Peter,

We have an intermittent problem when obtaining the stdout RP value of a
ws-gram job. We make 2 calls to obtain the value in case if fails. One
call is made after the job becomes active but sometimes the active
notification is not delivered or sent. The 2nd call is made after the
'Done' notification is received and before the ws-gram job object is
destroyed. Sometimes it happens that we do not receive the active
notification and that the RP value is null when probing after receiving
the Done notification. the job i'm executing is a shell script which takes
little time to execute.

I'm using GT4.0.3

Thierry.
------- Comment #1 From 2006-10-18 17:23:44 -------
Created an attachment (id=1081) [details]
Gemlca log showing null RP

I've attached a part of a GEMLCA log. Please look at ServiceThread-6. A job is
submitted. There is no Active notification delivered. It goes sraight into
Cleanup and Done. The RP is checked right after the job is done (as we did not
get an active notification) but the RP is null.

I can usually reproduce this when submitting multiple (4 to 8) jobs at the same
time to ws-gram.
------- Comment #2 From 2007-09-19 11:38:04 -------
Reassigning to current GRAM developer to close/fix as appropriate.
------- Comment #3 From 2008-02-05 15:24:30 -------
We have not seen this behavior with recent versions of WS GRAM (4.0.5 and
4.0.6)  We've had 500 concurrent globusrun-ws clients which fetch the stdout
RP.  There have been many improvements since 4.0.3 and apparently this has been
fixed.