Bug 4789 - GW hangs with log4j.category.org.globus.wsrf.handlers.MessageLoggingHandler=DEBUG
: GW hangs with log4j.category.org.globus.wsrf.handlers.MessageLoggingHandler=D...
Status: CLOSED WORKSFORME
: Gridway
Core
: 5.0
: Other All
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2006-10-18 09:05 by
Modified: 2008-03-28 11:13 (History)


Attachments
patch for bug 4789 (810 bytes, patch)
2006-12-05 05:50, Ruben S. Montero
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-10-18 09:05:41
This error has been reported by Ping

Originally, I opened 

log4j.category.org.globus.wsrf.handlers.MessageLoggingHandler=DEBUG

in 'log4j.properties' to give me more debugging
information about globus. When I had the problem that
gwd daemon was always killed whenever a job was
submitted to globus, this debugging option was open.

Last Friday, I commented it out when I tested WS MAD
since with it open, I got too many SOAP messages.
Right after I confirmed WS MAD worked very well, I
tested gwd and submitted jobs to see if gwd was
stable. As you already know, gwd worked very well. At
that moment, I didn't associate the log option with
the behavior of gwd.

Anyway, here the problem comes again after I uncomment
that debug option. I am attaching the debugging stack
and the gwd.log.
------- Comment #1 From 2006-12-05 05:50:50 -------
Created an attachment (id=1136) [details]
patch for bug 4789
------- Comment #2 From 2006-12-05 07:05:52 -------
(From update of attachment 1136 [details])
This patch id for bug 4876!!