Bug 4771 - date bug in job manager log file
: date bug in job manager log file
Status: RESOLVED DUPLICATE of bug 1538
: GRAM
gt2 Gatekeeper/Jobmanager
: unspecified
: All All
: P3 minor
: 4.2.1
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2006-10-13 06:53 by
Modified: 2008-07-30 16:31 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-10-13 06:53:17
THere is a date format related bug in the log files based on that the year is
ot reported as part of log entries such as 

10/13 06:43:05 JM: exiting globus_gram_job_manager.

This must be changed to 

10/13/2006 06:43:05 JM: exiting globus_gram_job_manager.

Rationale: Programs can use the log file to calculate the actual running time
of batch jobs. However if the Job sould be run on the last day of the year this
will cause problems.
------- Comment #1 From 2006-10-13 09:12:02 -------
Fine.  Looks like a simple change, but severity is minor in my estimation
------- Comment #2 From 2006-10-13 09:16:58 -------
This log file is really meant for debugging purposes and the format of the
messages in it isn't really documented anywhere, so you are doing this
operation at your own risk. Can't you just assume jobs run for less than 1
year? 

You might be interested in the auditing work being done for [bug #4410], which
is an attempt to handle this sort of information in a better structured way.
------- Comment #3 From 2008-07-30 15:02:05 -------
We'll be merging in the patch for #1538 for 4.2.1 which includes an accounting
file which contains the job submission and termination time with full dates in
their timestamps. I'm marking this as a duplicate of that bug.

*** This bug has been marked as a duplicate of 1538 ***