Bug 4639 - globus_4_0_2 tag, java-only installation
: globus_4_0_2 tag, java-only installation
Status: RESOLVED FIXED
: RFT
RFT
: 4.0.2
: Macintosh All
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2006-08-03 11:22 by
Modified: 2006-08-22 09:45 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-08-03 11:22:22
Very messy startup message from a globus_4_0_2 tagged java-only installation. 
I ran "bin/grid-proxy-init", then "bin/globus-start-container" after setting my
GLOBUS_LOCATION.

Available at http://www-unix.mcs.anl.gov/~bacon/java-only.tar.gz

In the jndi-config.xml:
            <parameter>
                <name>
                connectionString
                </name>
                <value>
                jdbc:postgresql://127.0.0.1/rftDatabase
                </value>
            </parameter>
            <parameter>
                <name>
                userName
                </name>
                <value>
                globus
                </value>
            </parameter>
            <parameter>
                <name>
                password
                </name>
                <value>
                changeme
                </value>

There is no postgresql database available at that location/username/password.

wireless-224-14:~/tmp/tmp/java-only bacon$ bin/globus-start-container 
2006-08-03 11:19:09,418 ERROR database.RFTDatabaseSetup
[main,getDBConnection:205] Unable to connect to database.Connection refused.
Check that the hostname and port are correct and that the postmaster is
accepting TCP/IP connections.
Connection refused. Check that the hostname and port are correct and that the
postmaster is accepting TCP/IP connections.
        at
org.postgresql.jdbc1.AbstractJdbc1Connection.openConnection(AbstractJdbc1Connection.java:167)
        at org.postgresql.Driver.connect(Driver.java:122)
        at java.sql.DriverManager.getConnection(DriverManager.java:525)
        at java.sql.DriverManager.getConnection(DriverManager.java:171)
        at
org.apache.commons.dbcp.DriverManagerConnectionFactory.createConnection(DriverManagerConnectionFactory.java:48)
        at
org.apache.commons.dbcp.PoolableConnectionFactory.makeObject(PoolableConnectionFactory.java:290)
        at
org.apache.commons.pool.impl.GenericObjectPool.borrowObject(GenericObjectPool.java:771)
        at
org.apache.commons.dbcp.PoolingDriver.connect(PoolingDriver.java:175)
        at java.sql.DriverManager.getConnection(DriverManager.java:525)
        at java.sql.DriverManager.getConnection(DriverManager.java:193)
        at
org.globus.transfer.reliable.service.database.RFTDatabaseSetup.getDBConnection(RFTDatabaseSetup.java:200)
        at
org.globus.transfer.reliable.service.database.ReliableFileTransferDbAdapter.setSchemaVersion(ReliableFileTransferDbAdapter.java:385)
        at
org.globus.transfer.reliable.service.database.ReliableFileTransferDbAdapter.setup(ReliableFileTransferDbAdapter.java:128)
        at
org.globus.transfer.reliable.service.ReliableFileTransferImpl.<init>(ReliableFileTransferImpl.java:65)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
Method)
        at
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
        at
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
        at java.lang.Class.newInstance0(Class.java:350)
        at java.lang.Class.newInstance(Class.java:303)
        at
org.globus.axis.providers.RPCProvider.getNewServiceInstance(RPCProvider.java:115)
        at
org.globus.axis.description.ServiceDescUtil.initializeProviders(ServiceDescUtil.java:190)
        at
org.globus.axis.description.ServiceDescUtil.initializeService(ServiceDescUtil.java:135)
        at
org.globus.wsrf.container.ServiceManager$InitPrivilegedAction.initialize(ServiceManager.java:252)
        at
org.globus.wsrf.container.ServiceManager$InitPrivilegedAction.run(ServiceManager.java:264)
        at java.security.AccessController.doPrivileged(Native Method)
        at javax.security.auth.Subject.doAs(Subject.java:396)
        at org.globus.gsi.jaas.GlobusSubject.runAs(GlobusSubject.java:55)
        at org.globus.gsi.jaas.JaasSubject.doAs(JaasSubject.java:90)
        at
org.globus.wsrf.container.ServiceManager.initializeService(ServiceManager.java:218)
        at
org.globus.wsrf.container.ServiceManager.start(ServiceManager.java:148)
        at
org.globus.wsrf.container.ServiceDispatcher.init(ServiceDispatcher.java:131)
        at
org.globus.wsrf.container.ServiceContainer.start(ServiceContainer.java:237)
        at
org.globus.wsrf.container.ServiceContainer.<init>(ServiceContainer.java:195)
        at
org.globus.wsrf.container.GSIServiceContainer.<init>(GSIServiceContainer.java:45)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
Method)
        at
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
        at
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
        at
org.globus.wsrf.container.ServiceContainer.createContainer(ServiceContainer.java:136)
        at
org.globus.wsrf.container.ServiceContainer.startSecurityContainer(ServiceContainer.java:449)
        at
org.globus.wsrf.container.ServiceContainer.main(ServiceContainer.java:403)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.globus.bootstrap.BootstrapBase.launch(BootstrapBase.java:95)
        at org.globus.bootstrap.Bootstrap.main(Bootstrap.java:37)
2006-08-03 11:19:09,451 ERROR service.ReliableFileTransferImpl [main,<init>:68]
Unable to setup database driver with pooling.Unable to connect to
database.Connection refused. Check that the hostname and port are correct and
that the postmaster is accepting TCP/IP connections. [Caused by: Connection
refused. Check that the hostname and port are correct and that the postmaster
is accepting TCP/IP connections.]
2006-08-03 11:19:10,688 ERROR database.RFTDatabaseSetup
[main,getDBConnection:205] Unable to connect to database.Connection refused.
Check that the hostname and port are correct and that the postmaster is
accepting TCP/IP connections.
Connection refused. Check that the hostname and port are correct and that the
postmaster is accepting TCP/IP connections.
        at
org.postgresql.jdbc1.AbstractJdbc1Connection.openConnection(AbstractJdbc1Connection.java:167)
        at org.postgresql.Driver.connect(Driver.java:122)
        at java.sql.DriverManager.getConnection(DriverManager.java:525)
        at java.sql.DriverManager.getConnection(DriverManager.java:171)
        at
org.apache.commons.dbcp.DriverManagerConnectionFactory.createConnection(DriverManagerConnectionFactory.java:48)
        at
org.apache.commons.dbcp.PoolableConnectionFactory.makeObject(PoolableConnectionFactory.java:290)
        at
org.apache.commons.pool.impl.GenericObjectPool.borrowObject(GenericObjectPool.java:771)
        at
org.apache.commons.dbcp.PoolingDriver.connect(PoolingDriver.java:175)
        at java.sql.DriverManager.getConnection(DriverManager.java:525)
        at java.sql.DriverManager.getConnection(DriverManager.java:193)
        at
org.globus.transfer.reliable.service.database.RFTDatabaseSetup.getDBConnection(RFTDatabaseSetup.java:200)
        at
org.globus.transfer.reliable.service.database.ReliableFileTransferDbAdapter.getActiveRequestIds(ReliableFileTransferDbAdapter.java:736)
        at
org.globus.transfer.reliable.service.ReliableFileTransferResource.getStoredResourceKeyValues(ReliableFileTransferResource.java:541)
        at
org.globus.transfer.reliable.service.ReliableFileTransferHome.initialize(ReliableFileTransferHome.java:63)
        at
org.globus.wsrf.jndi.BasicBeanFactory.getObjectInstance(BasicBeanFactory.java:38)
        at org.globus.wsrf.jndi.BeanFactory.getInstance(BeanFactory.java:113)
        at org.globus.wsrf.jndi.BeanFactory.access$100(BeanFactory.java:34)
        at
org.globus.wsrf.jndi.BeanFactory$GetInstanceAction.run(BeanFactory.java:137)
        at java.security.AccessController.doPrivileged(Native Method)
        at javax.security.auth.Subject.doAs(Subject.java:396)
        at org.globus.gsi.jaas.GlobusSubject.runAs(GlobusSubject.java:55)
        at org.globus.gsi.jaas.JaasSubject.doAs(JaasSubject.java:90)
        at
org.globus.wsrf.jndi.BeanFactory.getObjectInstance(BeanFactory.java:84)
        at org.apache.naming.factory.ResourceFactory.getObjectInstance(Unknown
Source)
        at
javax.naming.spi.NamingManager.getObjectInstance(NamingManager.java:304)
        at org.apache.naming.NamingContext.lookup(Unknown Source)
        at org.apache.naming.NamingContext.lookup(Unknown Source)
        at org.apache.naming.SynchronizedContext.lookup(Unknown Source)
        at org.apache.naming.NamingContext.lookup(Unknown Source)
        at org.apache.naming.NamingContext.lookup(Unknown Source)
        at org.apache.naming.SynchronizedContext.lookup(Unknown Source)
        at org.apache.naming.NamingContext.lookup(Unknown Source)
        at org.apache.naming.NamingContext.lookup(Unknown Source)
        at org.apache.naming.SynchronizedContext.lookup(Unknown Source)
        at org.apache.naming.NamingContext.lookup(Unknown Source)
        at org.apache.naming.NamingContext.lookup(Unknown Source)
        at org.apache.naming.SynchronizedContext.lookup(Unknown Source)
        at org.apache.naming.NamingContext.lookup(Unknown Source)
        at org.apache.naming.NamingContext.lookup(Unknown Source)
        at org.apache.naming.SynchronizedContext.lookup(Unknown Source)
        at javax.naming.InitialContext.lookup(InitialContext.java:351)
        at org.apache.naming.SelectorContext.lookup(Unknown Source)
        at javax.naming.InitialContext.lookup(InitialContext.java:351)
        at
org.globus.wsrf.impl.ResourceContextImpl.getResourceHome(ResourceContextImpl.java:119)
        at
org.globus.wsrf.container.ServiceManager$InitPrivilegedAction.initialize(ServiceManager.java:257)
        at
org.globus.wsrf.container.ServiceManager$InitPrivilegedAction.run(ServiceManager.java:264)
        at java.security.AccessController.doPrivileged(Native Method)
        at javax.security.auth.Subject.doAs(Subject.java:396)
        at org.globus.gsi.jaas.GlobusSubject.runAs(GlobusSubject.java:55)
        at org.globus.gsi.jaas.JaasSubject.doAs(JaasSubject.java:90)
        at
org.globus.wsrf.container.ServiceManager.initializeService(ServiceManager.java:218)
        at
org.globus.wsrf.container.ServiceManager.start(ServiceManager.java:148)
        at
org.globus.wsrf.container.ServiceDispatcher.init(ServiceDispatcher.java:131)
        at
org.globus.wsrf.container.ServiceContainer.start(ServiceContainer.java:237)
        at
org.globus.wsrf.container.ServiceContainer.<init>(ServiceContainer.java:195)
        at
org.globus.wsrf.container.GSIServiceContainer.<init>(GSIServiceContainer.java:45)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
Method)
        at
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
        at
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
        at
org.globus.wsrf.container.ServiceContainer.createContainer(ServiceContainer.java:136)
        at
org.globus.wsrf.container.ServiceContainer.startSecurityContainer(ServiceContainer.java:449)
        at
org.globus.wsrf.container.ServiceContainer.main(ServiceContainer.java:403)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.globus.bootstrap.BootstrapBase.launch(BootstrapBase.java:95)
        at org.globus.bootstrap.Bootstrap.main(Bootstrap.java:37)
------- Comment #1 From 2006-08-04 09:36:11 -------
Yeah I have the same error too. I am using globus 4.0.2. I would appreciate any
help or advice. 

2006-08-03 15:42:59,279 ERROR factory.ActiveResourceInstancesRP
[ServiceThread-10,getActiveTransferResourceCount:65] Error retrieving data from
database for id:
 "{0}"
Unable to connect to database.Connection refused. Check that the hostname and
port are correct and that the postmaster is accepting TCP/IP connections.
 Caused by
Connection refused. Check that the hostname and port are correct and that the
postmaster is accepting TCP/IP connections.
        at
org.postgresql.jdbc1.AbstractJdbc1Connection.openConnection(AbstractJdbc1Connection.java:167)
        at org.postgresql.Driver.connect(Driver.java:122)
        at java.sql.DriverManager.getConnection(DriverManager.java:525)
        at java.sql.DriverManager.getConnection(DriverManager.java:171)
        at
org.apache.commons.dbcp.DriverManagerConnectionFactory.createConnection(DriverManagerConnectionFactory.java:48)
        at
org.apache.commons.dbcp.PoolableConnectionFactory.makeObject(PoolableConnectionFactory.java:290)
        at
org.apache.commons.pool.impl.GenericObjectPool.borrowObject(GenericObjectPool.java:771)
        at
org.apache.commons.dbcp.PoolingDriver.connect(PoolingDriver.java:175)
        at java.sql.DriverManager.getConnection(DriverManager.java:525)
        at java.sql.DriverManager.getConnection(DriverManager.java:193)
        at
org.globus.transfer.reliable.service.database.RFTDatabaseSetup.getDBConnection(RFTDatabaseSetup.java:200)
        at
org.globus.transfer.reliable.service.database.ReliableFileTransferDbAdapter.getActiveRequestIds(ReliableFileTransferDbAdapter.java:736)
        at
org.globus.transfer.reliable.service.factory.ActiveResourceInstancesRP.getActiveTransferResourceCount(ActiveResourceInstancesRP.java:62)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at
org.globus.wsrf.impl.ReflectionResourceProperty.getValueSimple(ReflectionResourceProperty.java:340)
        at
org.globus.wsrf.impl.ReflectionResourceProperty.toSOAPElementSimple(ReflectionResourceProperty.java:431)
        at
org.globus.wsrf.impl.ReflectionResourceProperty.toSOAPElements(ReflectionResourceProperty.java:320)
        at
org.globus.wsrf.impl.properties.GetMultipleResourcePropertiesProvider.getMultipleResourceProperties(GetMultipleResourcePropertiesProvider.java:97)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at
org.apache.axis.providers.java.RPCProvider.invokeMethod(RPCProvider.java:384)
        at
org.globus.axis.providers.RPCProvider.invokeMethodSub(RPCProvider.java:107)
        at
org.globus.axis.providers.PrivilegedInvokeMethodAction.run(PrivilegedInvokeMethodAction.java:42)
        at java.security.AccessController.doPrivileged(Native Method)
        at javax.security.auth.Subject.doAs(Subject.java:396)
        at org.globus.gsi.jaas.GlobusSubject.runAs(GlobusSubject.java:55)
        at org.globus.gsi.jaas.JaasSubject.doAs(JaasSubject.java:90)
        at
org.globus.axis.providers.RPCProvider.invokeMethod(RPCProvider.java:97)
        at
org.apache.axis.providers.java.RPCProvider.processMessage(RPCProvider.java:281)
        at
org.apache.axis.providers.java.JavaProvider.invoke(JavaProvider.java:319)
        at
org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
        at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
        at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
        at
org.apache.axis.handlers.soap.SOAPService.invoke(SOAPService.java:450)       
at org.apache.axis.server.AxisServer.invoke(AxisServer.java:285)
        at
org.globus.wsrf.container.ServiceThread.doPost(ServiceThread.java:676)       
at org.globus.wsrf.container.ServiceThread.process(ServiceThread.java:397)
        at org.globus.wsrf.container.ServiceThread.run(ServiceThread.java:302)


(In reply to comment #0)
> Very messy startup message from a globus_4_0_2 tagged java-only installation. 
> I ran "bin/grid-proxy-init", then "bin/globus-start-container" after setting my
> GLOBUS_LOCATION.
> 
> Available at http://www-unix.mcs.anl.gov/~bacon/java-only.tar.gz
> 
> In the jndi-config.xml:
>             <parameter>
>                 <name>
>                 connectionString
>                 </name>
>                 <value>
>                 jdbc:postgresql://127.0.0.1/rftDatabase
>                 </value>
>             </parameter>
>             <parameter>
>                 <name>
>                 userName
>                 </name>
>                 <value>
>                 globus
>                 </value>
>             </parameter>
>             <parameter>
>                 <name>
>                 password
>                 </name>
>                 <value>
>                 changeme
>                 </value>
> 
> There is no postgresql database available at that location/username/password.
> 
> wireless-224-14:~/tmp/tmp/java-only bacon$ bin/globus-start-container 
> 2006-08-03 11:19:09,418 ERROR database.RFTDatabaseSetup
> [main,getDBConnection:205] Unable to connect to database.Connection refused.
> Check that the hostname and port are correct and that the postmaster is
> accepting TCP/IP connections.
> Connection refused. Check that the hostname and port are correct and that the
> postmaster is accepting TCP/IP connections.
>         at
> org.postgresql.jdbc1.AbstractJdbc1Connection.openConnection(AbstractJdbc1Connection.java:167)
>         at org.postgresql.Driver.connect(Driver.java:122)
>         at java.sql.DriverManager.getConnection(DriverManager.java:525)
>         at java.sql.DriverManager.getConnection(DriverManager.java:171)
>         at
> org.apache.commons.dbcp.DriverManagerConnectionFactory.createConnection(DriverManagerConnectionFactory.java:48)
>         at
> org.apache.commons.dbcp.PoolableConnectionFactory.makeObject(PoolableConnectionFactory.java:290)
>         at
> org.apache.commons.pool.impl.GenericObjectPool.borrowObject(GenericObjectPool.java:771)
>         at
> org.apache.commons.dbcp.PoolingDriver.connect(PoolingDriver.java:175)
>         at java.sql.DriverManager.getConnection(DriverManager.java:525)
>         at java.sql.DriverManager.getConnection(DriverManager.java:193)
>         at
> org.globus.transfer.reliable.service.database.RFTDatabaseSetup.getDBConnection(RFTDatabaseSetup.java:200)
>         at
> org.globus.transfer.reliable.service.database.ReliableFileTransferDbAdapter.setSchemaVersion(ReliableFileTransferDbAdapter.java:385)
>         at
> org.globus.transfer.reliable.service.database.ReliableFileTransferDbAdapter.setup(ReliableFileTransferDbAdapter.java:128)
>         at
> org.globus.transfer.reliable.service.ReliableFileTransferImpl.<init>(ReliableFileTransferImpl.java:65)
>         at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
> Method)
>         at
> sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
>         at
> sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
>         at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
>         at java.lang.Class.newInstance0(Class.java:350)
>         at java.lang.Class.newInstance(Class.java:303)
>         at
> org.globus.axis.providers.RPCProvider.getNewServiceInstance(RPCProvider.java:115)
>         at
> org.globus.axis.description.ServiceDescUtil.initializeProviders(ServiceDescUtil.java:190)
>         at
> org.globus.axis.description.ServiceDescUtil.initializeService(ServiceDescUtil.java:135)
>         at
> org.globus.wsrf.container.ServiceManager$InitPrivilegedAction.initialize(ServiceManager.java:252)
>         at
> org.globus.wsrf.container.ServiceManager$InitPrivilegedAction.run(ServiceManager.java:264)
>         at java.security.AccessController.doPrivileged(Native Method)
>         at javax.security.auth.Subject.doAs(Subject.java:396)
>         at org.globus.gsi.jaas.GlobusSubject.runAs(GlobusSubject.java:55)
>         at org.globus.gsi.jaas.JaasSubject.doAs(JaasSubject.java:90)
>         at
> org.globus.wsrf.container.ServiceManager.initializeService(ServiceManager.java:218)
>         at
> org.globus.wsrf.container.ServiceManager.start(ServiceManager.java:148)
>         at
> org.globus.wsrf.container.ServiceDispatcher.init(ServiceDispatcher.java:131)
>         at
> org.globus.wsrf.container.ServiceContainer.start(ServiceContainer.java:237)
>         at
> org.globus.wsrf.container.ServiceContainer.<init>(ServiceContainer.java:195)
>         at
> org.globus.wsrf.container.GSIServiceContainer.<init>(GSIServiceContainer.java:45)
>         at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
> Method)
>         at
> sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
>         at
> sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
>         at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
>         at
> org.globus.wsrf.container.ServiceContainer.createContainer(ServiceContainer.java:136)
>         at
> org.globus.wsrf.container.ServiceContainer.startSecurityContainer(ServiceContainer.java:449)
>         at
> org.globus.wsrf.container.ServiceContainer.main(ServiceContainer.java:403)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>         at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>         at java.lang.reflect.Method.invoke(Method.java:585)
>         at org.globus.bootstrap.BootstrapBase.launch(BootstrapBase.java:95)
>         at org.globus.bootstrap.Bootstrap.main(Bootstrap.java:37)
> 2006-08-03 11:19:09,451 ERROR service.ReliableFileTransferImpl [main,<init>:68]
> Unable to setup database driver with pooling.Unable to connect to
> database.Connection refused. Check that the hostname and port are correct and
> that the postmaster is accepting TCP/IP connections. [Caused by: Connection
> refused. Check that the hostname and port are correct and that the postmaster
> is accepting TCP/IP connections.]
> 2006-08-03 11:19:10,688 ERROR database.RFTDatabaseSetup
> [main,getDBConnection:205] Unable to connect to database.Connection refused.
> Check that the hostname and port are correct and that the postmaster is
> accepting TCP/IP connections.
> Connection refused. Check that the hostname and port are correct and that the
> postmaster is accepting TCP/IP connections.
>         at
> org.postgresql.jdbc1.AbstractJdbc1Connection.openConnection(AbstractJdbc1Connection.java:167)
>         at org.postgresql.Driver.connect(Driver.java:122)
>         at java.sql.DriverManager.getConnection(DriverManager.java:525)
>         at java.sql.DriverManager.getConnection(DriverManager.java:171)
>         at
> org.apache.commons.dbcp.DriverManagerConnectionFactory.createConnection(DriverManagerConnectionFactory.java:48)
>         at
> org.apache.commons.dbcp.PoolableConnectionFactory.makeObject(PoolableConnectionFactory.java:290)
>         at
> org.apache.commons.pool.impl.GenericObjectPool.borrowObject(GenericObjectPool.java:771)
>         at
> org.apache.commons.dbcp.PoolingDriver.connect(PoolingDriver.java:175)
>         at java.sql.DriverManager.getConnection(DriverManager.java:525)
>         at java.sql.DriverManager.getConnection(DriverManager.java:193)
>         at
> org.globus.transfer.reliable.service.database.RFTDatabaseSetup.getDBConnection(RFTDatabaseSetup.java:200)
>         at
> org.globus.transfer.reliable.service.database.ReliableFileTransferDbAdapter.getActiveRequestIds(ReliableFileTransferDbAdapter.java:736)
>         at
> org.globus.transfer.reliable.service.ReliableFileTransferResource.getStoredResourceKeyValues(ReliableFileTransferResource.java:541)
>         at
> org.globus.transfer.reliable.service.ReliableFileTransferHome.initialize(ReliableFileTransferHome.java:63)
>         at
> org.globus.wsrf.jndi.BasicBeanFactory.getObjectInstance(BasicBeanFactory.java:38)
>         at org.globus.wsrf.jndi.BeanFactory.getInstance(BeanFactory.java:113)
>         at org.globus.wsrf.jndi.BeanFactory.access$100(BeanFactory.java:34)
>         at
> org.globus.wsrf.jndi.BeanFactory$GetInstanceAction.run(BeanFactory.java:137)
>         at java.security.AccessController.doPrivileged(Native Method)
>         at javax.security.auth.Subject.doAs(Subject.java:396)
>         at org.globus.gsi.jaas.GlobusSubject.runAs(GlobusSubject.java:55)
>         at org.globus.gsi.jaas.JaasSubject.doAs(JaasSubject.java:90)
>         at
> org.globus.wsrf.jndi.BeanFactory.getObjectInstance(BeanFactory.java:84)
>         at org.apache.naming.factory.ResourceFactory.getObjectInstance(Unknown
> Source)
>         at
> javax.naming.spi.NamingManager.getObjectInstance(NamingManager.java:304)
>         at org.apache.naming.NamingContext.lookup(Unknown Source)
>         at org.apache.naming.NamingContext.lookup(Unknown Source)
>         at org.apache.naming.SynchronizedContext.lookup(Unknown Source)
>         at org.apache.naming.NamingContext.lookup(Unknown Source)
>         at org.apache.naming.NamingContext.lookup(Unknown Source)
>         at org.apache.naming.SynchronizedContext.lookup(Unknown Source)
>         at org.apache.naming.NamingContext.lookup(Unknown Source)
>         at org.apache.naming.NamingContext.lookup(Unknown Source)
>         at org.apache.naming.SynchronizedContext.lookup(Unknown Source)
>         at org.apache.naming.NamingContext.lookup(Unknown Source)
>         at org.apache.naming.NamingContext.lookup(Unknown Source)
>         at org.apache.naming.SynchronizedContext.lookup(Unknown Source)
>         at org.apache.naming.NamingContext.lookup(Unknown Source)
>         at org.apache.naming.NamingContext.lookup(Unknown Source)
>         at org.apache.naming.SynchronizedContext.lookup(Unknown Source)
>         at javax.naming.InitialContext.lookup(InitialContext.java:351)
>         at org.apache.naming.SelectorContext.lookup(Unknown Source)
>         at javax.naming.InitialContext.lookup(InitialContext.java:351)
>         at
> org.globus.wsrf.impl.ResourceContextImpl.getResourceHome(ResourceContextImpl.java:119)
>         at
> org.globus.wsrf.container.ServiceManager$InitPrivilegedAction.initialize(ServiceManager.java:257)
>         at
> org.globus.wsrf.container.ServiceManager$InitPrivilegedAction.run(ServiceManager.java:264)
>         at java.security.AccessController.doPrivileged(Native Method)
>         at javax.security.auth.Subject.doAs(Subject.java:396)
>         at org.globus.gsi.jaas.GlobusSubject.runAs(GlobusSubject.java:55)
>         at org.globus.gsi.jaas.JaasSubject.doAs(JaasSubject.java:90)
>         at
> org.globus.wsrf.container.ServiceManager.initializeService(ServiceManager.java:218)
>         at
> org.globus.wsrf.container.ServiceManager.start(ServiceManager.java:148)
>         at
> org.globus.wsrf.container.ServiceDispatcher.init(ServiceDispatcher.java:131)
>         at
> org.globus.wsrf.container.ServiceContainer.start(ServiceContainer.java:237)
>         at
> org.globus.wsrf.container.ServiceContainer.<init>(ServiceContainer.java:195)
>         at
> org.globus.wsrf.container.GSIServiceContainer.<init>(GSIServiceContainer.java:45)
>         at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
> Method)
>         at
> sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
>         at
> sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
>         at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
>         at
> org.globus.wsrf.container.ServiceContainer.createContainer(ServiceContainer.java:136)
>         at
> org.globus.wsrf.container.ServiceContainer.startSecurityContainer(ServiceContainer.java:449)
>         at
> org.globus.wsrf.container.ServiceContainer.main(ServiceContainer.java:403)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>         at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>         at java.lang.reflect.Method.invoke(Method.java:585)
>         at org.globus.bootstrap.BootstrapBase.launch(BootstrapBase.java:95)
>         at org.globus.bootstrap.Bootstrap.main(Bootstrap.java:37)
> 
------- Comment #2 From 2006-08-04 14:37:02 -------
fix in globus_4_0_branch
------- Comment #3 From 2006-08-04 15:01:49 -------
Hi Ravi,

I still don't  understand what do you mean. Sorry, this is my first time try
out Globus toolkit 4. Could you please explain me more detail. I really
appreciate your help. Btw, I am using Linux

-Lani
------- Comment #4 From 2006-08-04 15:23:12 -------
Lani - your stack trace does not look the same as the specific stack trace
being described in this bug.  If you require assistance, please email
gt-user@globus.org or rft-user@globus.org.  Thanks!