Bug 4563 - Job states get mixed
: Job states get mixed
Status: CLOSED WORKSFORME
: Gridway
Core
: 5.0
: PC Linux
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2006-07-03 10:04 by
Modified: 2008-03-28 11:13 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-07-03 10:04:18
Dear all,

It happens that GridWay mixes arriving job states if monitoring a big amount of
jobs. A "handmade" solution is to raise the POLL_INTERVAL value in gwd.conf,
but making GridWay wait for a job state before polling again would be very nice
:-).
------- Comment #1 From 2006-09-19 06:26:14 -------
This bug is tightly related with the GRAM version used in EGEE. There are two
possible solutions:
 1.- Not polling a job until the callback of the previous polling action is
received. In general, we do not want this since a callback could be lost, and
so blocking further polling on the job.
 2.- Time out polls, which in turn is equivalent to increment the poll
time-out.

I could not reproduce the behavior described neither with GRAM-WS nor with
pre-WS GRAM from GT4.0.X. I have been also trying to reproduced it with the
EGEE testbed without success. I change the resolution to "WORKS FOR ME", we can
reopen the bug later if the situation arises again and we have more info.