Bug 4539 - Add script error #21 troubleshooting information.
: Add script error #21 troubleshooting information.
Status: CLOSED FIXED
: Documentation
Execution Management
: unspecified
: PC Linux
: P3 normal
: 4.0
Assigned To:
:
:
: 4174
:
  Show dependency treegraph
 
Reported: 2006-06-21 12:22 by
Modified: 2007-06-27 10:00 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-06-21 12:22:10
When a user gets the following error:

The globus-job-manager-script.pl script received a bad argument.
Check for the existance of the appropriate resource manager adapter Perl
module in the ${GLOBUS_LOCATION}/lib/perl/Globus/GRAM/JobManager/ directory.

this is a result of GLOBUS::GRAM::BAD_SCRIPT_ARG_FILE being sent back on stdout
from globus-job-manager-script.pl. The possible causes of this error are as
follows:

1) the -m option isn't specified to globus-job-manager-script.pl script,
2) the -f option isn't specified to globus-job-manager-script.pl script,
3) the -f option isn't specified to globus-job-manager-script.pl script,
4) the resource manager adapter module (i.e. fork.pm, pbs.pm, etc...) cannot be
found,
5) and instance of the resource manager adapter module could not be
instantiated, or
6) the logfile extension points to a filename that cannot be opened for writing

1-3 are extremely unlikely to be the cause, so there should be documentation
focusing on 4-6 as the likely causes of this error. It may be necessary to
redirect the reader to the script troubleshooting section.
------- Comment #1 From 2007-05-03 10:51:59 -------
I got this error, after i installed the GT on my new Laptop.
The reason for that is probably in all cases, where the perl
extension handler is used, the missing Perl module XML::Parser.
After i installed that module submission worked fine.
See also bug #4174