Bug 4518 - SEG issues DONE for FAILED jobs
: SEG issues DONE for FAILED jobs
Status: RESOLVED FIXED
: GRAM
wsrf scheduler interface
: development
: PC Linux
: P3 normal
: 4.2
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2006-06-15 18:29 by
Modified: 2006-06-27 10:01 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-06-15 18:29:11
Warning: Do not start a service container while this test script is running.
test-fork-seg....# Test 1 got: "1" (test-fork-seg.pl at line 24)
#   Expected: "0"
#  test-fork-seg.pl line 24 is: skip($skip_all ? "Fork SEG not configured" : 0,
&run_test, 0);
test-fork-seg....FAILED test 1
        Failed 1/1 tests, 0.00% okay
Failed Test      Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------------
test-fork-seg.pl                1    1 100.00%  1
Failed 1/1 test scripts, 0.00% okay. 1/1 subtests failed, 0.00% okay.

I looked at the test data and I'm wondering if the problem is that the test
data doesn't have the extra junk on the job ID that was added to avoid problems
with PID reuse.
------- Comment #1 From 2006-06-27 08:58:54 -------
In the CVS trunk, there's an error in the SEG where it outputs a "DONE" event
when a job fails. The event contains an error code, so it looks like the
WS-GRAM service is ignoring the incorrect part of the message, but it is
causing the test cases to fail.
------- Comment #2 From 2006-06-27 09:00:23 -------
*** Bug 4519 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2006-06-27 09:00:42 -------
*** Bug 4520 has been marked as a duplicate of this bug. ***
------- Comment #4 From 2006-06-27 10:01:50 -------
Fix committed to trunk.