Bug 4366 - Bad 4.0.2 tag in ws-transfer?
: Bad 4.0.2 tag in ws-transfer?
Status: RESOLVED FIXED
: RFT
RFT
: development
: PC Linux
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2006-04-23 17:20 by
Modified: 2006-04-24 15:39 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-04-23 17:20:40
An installer created from the 4.0.2 tag will fail with:

gpt-build ====> CHECKING BUILD DEPENDENCIES FOR globus_c_rft_client_bindings
ERROR: The following packages are missing
Package compile-globus_c_wsrf_cgen-ANY-pgm version 0.21 is incompatible with
globus_c_rft_client_bindings-ANY-src


The problem is in
ws-transfer/reliable/client/c/bindings/pkgdata/pkg_data_src.gpt.in


      <Dependency Name="globus_c_wsrf_cgen" Package="pgm">
        <Version>
          <Simple_Version Major="2"/>
        </Version>
      </Dependency>


Major should be 0.


This looks like the pkgdata came from HEAD. globus_4_0_branch has Major as 0,
but HEAD has it as 2. Maybe the 4_0_2 tag was by mistake applied to a HEAD
checkout?
------- Comment #1 From 2006-04-24 07:48:41 -------
Mats
Charles fixed this on firday. Did you see this after friday ? 
------- Comment #2 From 2006-04-24 10:10:20 -------
Looks good now. I didn't hear anything on gt-dev, so I assumed more information
was needed. Closing as FIXED.
------- Comment #3 From 2006-04-24 15:39:56 -------
Yeah, sorry it was a silent fix.  Thanks for the report!