Bug 4325 - Exceptions of type 'expectedType' could be more useful
: Exceptions of type 'expectedType' could be more useful
Status: RESOLVED FIXED
: Java WS Core
globus_wsrf_core
: 4.0.1
: All All
: P3 contribution
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2006-04-05 11:56 by
Modified: 2006-04-06 16:57 (History)


Attachments
Adds the actual type recieved to the exception message. (5.94 KB, patch)
2006-04-05 11:58, Stuart Purdie
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-04-05 11:56:24
The set of exceptions that use the i18n message class 'expectedType' report the
desired type, but not the received type.  This additional information can be of
great use in diagnosing the cause of a problem.

Thus instead of:
Caused by: javax.naming.NamingException: Expected object of type
'org.globus.wsrf.utils.cache.Cache'.

it should say:
Caused by: javax.naming.NamingException: Expected object of type
'org.globus.wsrf.utils.cache.Cache', but got
'org.apache.naming.SynchronizedContext'
------- Comment #1 From 2006-04-05 11:58:11 -------
Created an attachment (id=922) [details]
Adds the actual type recieved to the exception message.

We've had this patch in use for a while now, found the extra information very
helpful.
------- Comment #2 From 2006-04-06 16:04:27 -------
Committed the changes to trunk so far.
------- Comment #3 From 2006-04-06 16:57:58 -------
Committed the changes to globus_4_0_branch.