Bug 4297 - PBS SEG module does not follow torque log rotation
: PBS SEG module does not follow torque log rotation
Status: RESOLVED FIXED
: GRAM
wsrf scheduler interface
: 4.0.1
: PC Linux
: P3 normal
: 4.0.2
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2006-03-16 16:31 by
Modified: 2006-03-21 15:24 (History)


Attachments
Use globus_libc_localtime_r instead of gmtime (1.03 KB, patch)
2006-03-17 15:05, Alexander V. Inyukhin
Details
Use globus_libc_localtime_r instead of gmtime (1.03 KB, patch)
2006-03-17 15:10, Alexander V. Inyukhin
Details
Use globus_libc_localtime_r instead of gmtime (1.03 KB, patch)
2006-03-17 15:12, Alexander V. Inyukhin
Details
Use globus_libc_localtime_r instead of gmtime (1.03 KB, patch)
2006-03-17 15:33, Alexander V. Inyukhin
Details
Use globus_libc_localtime_r instead of gmtime (1.03 KB, patch)
2006-03-17 15:38, Alexander V. Inyukhin
Details
Use globus_libc_localtime_r instead of gmtime (1.03 KB, patch)
2006-03-17 15:48, Alexander V. Inyukhin
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-03-16 16:31:46
globusrun-ws reports unsubmitted job state after torque's daily log rotation.

There are some additional info:
cluster:~# ps uxa | grep gt4 | grep pbs
gt4      23107  0.0  0.5  8212 5332 ?        S    Mar16   0:00
/opt/globus-4.0.1/libexec/globus-scheduler-event-generator -s pbs -t 1142441618
cluster:~# ls -l /proc/23107/fd
total 7
lr-x------  1 gt4 gt4 64 Mar 17 00:33 0 -> pipe:[25973370]
l-wx------  1 gt4 gt4 64 Mar 17 00:33 1 -> pipe:[25973371]
l-wx------  1 gt4 gt4 64 Mar 17 00:33 2 -> pipe:[25973372]
l-wx------  1 gt4 gt4 64 Mar 17 00:33 3 -> /dev/null
lr-x------  1 gt4 gt4 64 Mar 17 00:33 4 -> pipe:[25973380]
l-wx------  1 gt4 gt4 64 Mar 17 00:33 5 -> pipe:[25973380]
lr-x------  1 gt4 gt4 64 Mar 17 00:33 6 -> /var/spool/torque/server_logs/20060316
cluster:~# ls -l /var/spool/torque/server_logs/2006031[67]
-rw-r--r--  1 root root 4143097 Mar 17 00:00 /var/spool/torque/server_logs/20060316
-rw-r--r--  1 root root   11338 Mar 17 01:00 /var/spool/torque/server_logs/20060317
cluster:~# date
Fri Mar 17 01:02:16 MSK 2006
cluster:~# date -u
Thu Mar 16 22:02:17 UTC 2006

The last line of the /var/spool/torque//server_logs/20060316 is
03/17/2006 00:00:10;0002;PBS_Server;Svr;Log;Log closed

And on the client side:
$ globusrun-ws -submit -F imec.grid -Ft PBS -f rsl1.xml -s -so stdout -se stderr
Submitting job...Done.
Job ID: uuid:ce23c060-b538-11da-b403-00e018d25308
Termination time: 03/17/2006 22:04 GMT
Current job state: Unsubmitted

The version of globus_scheduler_event_generator_pbs package is 0.4.0.

How this problem could be fixed? Is it torque misconfiguration or SEG issue?
Thanks.
------- Comment #1 From 2006-03-17 08:34:16 -------
Does the latest update for that package on the advisories page
(http://www.globus.org/toolkit/advisories.html fix this issue for you?

------- Comment #2 From 2006-03-17 15:05:27 -------
Created an attachment (id=885) [details]
Use globus_libc_localtime_r instead of gmtime

(In reply to comment #1)
> Does the latest update for that package on the advisories page
> (http://www.globus.org/toolkit/advisories.html fix this issue for you?

I'm using the latest update already.

I think, the issue caused by gmtime call in seg_pbs_module.c:358.
Torque uses local timezone to rotate logs, but SEG determines date change
based on GMT timezone. So, it leads to 3-hour delay.

I've created a patch, and it works for me.
------- Comment #3 From 2006-03-17 15:10:41 -------
Created an attachment (id=886) [details]
Use globus_libc_localtime_r instead of gmtime

(In reply to comment #1)
> Does the latest update for that package on the advisories page
> (http://www.globus.org/toolkit/advisories.html fix this issue for you?

I'm using the latest update already.

I think, the issue caused by gmtime call in seg_pbs_module.c:358.
Torque uses local timezone to rotate logs, but SEG determines date change
based on GMT timezone. So, it leads to 3-hour delay.

I've created a patch, and it works for me.
------- Comment #4 From 2006-03-17 15:12:21 -------
Created an attachment (id=887) [details]
Use globus_libc_localtime_r instead of gmtime

(In reply to comment #1)
> Does the latest update for that package on the advisories page
> (http://www.globus.org/toolkit/advisories.html fix this issue for you?

I'm using the latest update already.

I think, the issue caused by gmtime call in seg_pbs_module.c:358.
Torque uses local timezone to rotate logs, but SEG determines date change
based on GMT timezone. So, it leads to 3-hour delay.

I've created a patch, and it works for me.
------- Comment #5 From 2006-03-17 15:33:59 -------
Created an attachment (id=888) [details]
Use globus_libc_localtime_r instead of gmtime

(In reply to comment #1)
> Does the latest update for that package on the advisories page
> (http://www.globus.org/toolkit/advisories.html fix this issue for you?

I'm using the latest update already.

I think, the issue caused by gmtime call in seg_pbs_module.c:358.
Torque uses local timezone to rotate logs, but SEG determines date change
based on GMT timezone. So, it leads to 3-hour delay.

I've created a patch, and it works for me.
------- Comment #6 From 2006-03-17 15:38:41 -------
Created an attachment (id=889) [details]
Use globus_libc_localtime_r instead of gmtime

(In reply to comment #1)
> Does the latest update for that package on the advisories page
> (http://www.globus.org/toolkit/advisories.html fix this issue for you?

I'm using the latest update already.

I think, the issue caused by gmtime call in seg_pbs_module.c:358.
Torque uses local timezone to rotate logs, but SEG determines date change
based on GMT timezone. So, it leads to 3-hour delay.

I've created a patch, and it works for me.
------- Comment #7 From 2006-03-17 15:48:59 -------
Created an attachment (id=890) [details]
Use globus_libc_localtime_r instead of gmtime

(In reply to comment #1)
> Does the latest update for that package on the advisories page
> (http://www.globus.org/toolkit/advisories.html fix this issue for you?

I'm using the latest update already.

I think, the issue caused by gmtime call in seg_pbs_module.c:358.
Torque uses local timezone to rotate logs, but SEG determines date change
based on GMT timezone. So, it leads to 3-hour delay.

I've created a patch, and it works for me.
------- Comment #8 From 2006-03-21 15:24:39 -------
I've committed a fix for this to CVS. Thanks for your help tracking this down.