Bug 4280 - GridFtp server could not take long home directory name
: GridFtp server could not take long home directory name
Status: RESOLVED FIXED
: GridFTP
GridFTP
: 4.0.1
: PC Linux
: P3 critical
: 4.0.2
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2006-03-10 16:09 by
Modified: 2006-04-14 14:06 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-03-10 16:09:27
Hi,  GridFtp server could not take long home directory name.

if you have following line in /etc/passwd file, the GridFTP server don't know
how to handle it. it behaves in very strange way.  When you try to get the home
directory, it returns:  /Network/Servers/fmri00-aaaaa.tested.test.ucla.edu/Volumes

if the user name is long, it will not even handle it.  You could easily
reproduce the error my create a long home path name as the following.
I think the GridFTP server might have buffer-overflow implementation problem for
 the home directory.   

myuser:x:1025:20:User
Name2345:/Network/Servers/fmri00-aaaaa.tested.test.ucla.edu/Volumes/home/myuser:/bin/tcsh


Kejian
------- Comment #1 From 2006-03-10 17:08:29 -------
The architecture is 

Linux 2.6.10-1.770_FC2smp #1 SMP Sat Feb 26 19:46:59 EST 2005 x86_64 x86_64
x86_64 GNU/Linux

it seems that maximum path length is 51 

64 - 13 (ipc header size)  

Could you take a look what is going on in the implementation and fixed asap. 

Thank you very much. 


kejian


------- Comment #2 From 2006-03-10 17:16:34 -------
the bug is not there in GT3 Grid ftp server.   (in.ftpd) 
------- Comment #3 From 2006-03-11 02:27:41 -------
This may have already be fixed in CVS.  It looks like it is a side affect of 
bug 3902.  See if the updated package 
http://www-unix.mcs.anl.gov/~mlink/globus_gridftp_server-2.2.tar.gz
fixes the problem for you.  (Install with 'gpt-build -update 
globus_gridftp_server-2.2.tar.gz <flavor>' -- flavor is probably gcc32dbg or 
gcc64dbg).
------- Comment #4 From 2006-04-14 14:05:49 -------
Fixed in the 4.0.2 release.