Bug 4211 - -Sf and -Tf options not working for multi jobs
: -Sf and -Tf options not working for multi jobs
Status: RESOLVED FIXED
: GRAM
wsrf gram clients
: 4.0.1
: PC Linux
: P3 normal
: 4.2
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2006-02-10 11:49 by
Modified: 2006-04-06 11:14 (History)


Attachments
Multijob with a fileCleanUp directive in the subjob. (1.02 KB, text/plain)
2006-03-16 16:25, Peter Lane
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-02-10 11:49:06
Here's an excerpt from a discuss list email. Notice that there are no
stagingCredentialEndpoint or transferCredentialEndpoint elements in the SOAP
message dump of the job description.

----------------------------------------------
[fra283@ng2 tmp]$ globusrun-ws -dbg -Jf /tmp/job -Sf /tmp/job -Tf
/tmp/job -submit -f multiJobUnzipSnark2.xml
Submitting job...
=== REQUEST MESSAGE (length 4454) (time 1139536447.152181000) ===
<ns00:Envelope
xmlns:ns00="http://schemas.xmlsoap.org/soap/envelope/"><ns00:Header></ns
00:Header><ns00:Body><ns01:createManagedJob
xmlns:ns01="http://www.globus.org/namespaces/2004/10/gram/job"><ns01:Ini
tialTerminationTime>2006-02-11T01:54:06Z</ns01:InitialTerminationTime><n
s01:JobID>uuid:1e8b29d4-99d8-11da-90b3-aa000075b0c1</ns01:JobID><ns02:Su
bscribe
xmlns:ns02="http://docs.oasis-open.org/wsn/2004/06/wsn-WS-BaseNotificati
on-1.2-draft-01.xsd"><ns02:ConsumerReference><ns03:Address
xmlns:ns03="http://schemas.xmlsoap.org/ws/2004/03/addressing">https://ng
2.ivec.org:1122/wsrf/services/NotificationConsumerService</ns03:Address>
<ns03:ReferenceProperties
xmlns:ns03="http://schemas.xmlsoap.org/ws/2004/03/addressing"><ns06:Reso
urceID xmlns:ns04="http://www.w3.org/2001/XMLSchema-instance"
xmlns:ns05="http://www.w3.org/2001/XMLSchema"
xmlns:ns06="http://www.globus.org/docs.oasis-open.org/wsn/2004/06/wsn-WS
-BaseNotification-1.2-draft-01.wsdl"
ns04:type="ns05:string">1e8e2e2c-99d8-11da-90b3-aa000075b0c1</ns06:Resou
rceID></ns03:ReferenceProperties></ns02:ConsumerReference><ns02:TopicExp
ression
Dialect="http://docs.oasis-open.org/wsn/2004/06/TopicExpression/Simple"
xmlns:ns07="http://www.globus.org/namespaces/2004/10/gram/job/types">ns0
7:state</ns02:TopicExpression><ns02:UseNotify>true</ns02:UseNotify></ns0
2:Subscribe><ns08:multiJob
xmlns:ns08="http://www.globus.org/namespaces/2004/10/gram/job/descriptio
n"><ns08:factoryEndpoint><ns03:Address
xmlns:ns03="http://schemas.xmlsoap.org/ws/2004/03/addressing">https://ng
2.ivec.org:8443/wsrf/services/ManagedJobFactoryService</ns03:Address><ns
03:ReferenceProperties
xmlns:ns03="http://schemas.xmlsoap.org/ws/2004/03/addressing"><gram:Reso
urceID
xmlns:gram="http://www.globus.org/namespaces/2004/10/gram/job">Multi</gr
am:ResourceID></ns03:ReferenceProperties></ns08:factoryEndpoint><ns08:jo
bCredentialEndpoint
xmlns:ns04="http://www.w3.org/2001/XMLSchema-instance"><ns03:Address
xmlns:ns03="http://schemas.xmlsoap.org/ws/2004/03/addressing">https://19
2.65.130.182:8443/wsrf/services/DelegationService</ns03:Address><ns03:Re
ferenceProperties
xmlns:ns03="http://schemas.xmlsoap.org/ws/2004/03/addressing"><ns1:Deleg
ationKey
xmlns:ns1="http://www.globus.org/08/2004/delegationService">0cbb3bf0-99d
2-11da-b6f0-d0a088441f75</ns1:DelegationKey></ns03:ReferenceProperties><
ns1:ReferenceParameters
xmlns:ns1="http://schemas.xmlsoap.org/ws/2004/03/addressing"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:type="ns1:ReferenceParametersType"/></ns08:jobCredentialEndpoint><ns
08:directory>/usr/local/globus/</ns08:directory><ns08:count>1</ns08:coun
t><ns08:job><ns08:factoryEndpoint><ns03:Address
xmlns:ns03="http://schemas.xmlsoap.org/ws/2004/03/addressing">https://ng
2.ivec.org:8443/wsrf/services/ManagedJobFactoryService</ns03:Address><ns
03:ReferenceProperties
xmlns:ns03="http://schemas.xmlsoap.org/ws/2004/03/addressing"><gram:Reso
urceID
xmlns:gram="http://www.globus.org/namespaces/2004/10/gram/job">Fork</gra
m:ResourceID></ns03:ReferenceProperties></ns08:factoryEndpoint><ns08:exe
cutable>/bin/tar</ns08:executable><ns08:directory>/short/cg01/inputs</ns
08:directory><ns08:argument>xzf</ns08:argument><ns08:argument>inputs.tar
.gz</ns08:argument><ns08:stdout>/short/cg01/stdout</ns08:stdout><ns08:st
derr>/short/cg01/stderr</ns08:stderr><ns08:fileStageIn><ns09:transfer
xmlns:ns09="http://www.globus.org/namespaces/2004/10/rft"><ns09:sourceUr
l>gsiftp://fra283@ng2.ivec.org:5000/CSIRO-COMPGEO/home/fra283.CSIRO-COMP
GEO/input/inputs.tar.gz</ns09:sourceUrl><ns09:destinationUrl>file:///sho
rt/cg01/inputs/</ns09:destinationUrl></ns09:transfer><ns09:rftOptions
xmlns:ns09="http://www.globus.org/namespaces/2004/10/rft"><ns09:userName
>fra283</ns09:userName></ns09:rftOptions></ns08:fileStageIn></ns08:job><
ns08:job><ns08:factoryEndpoint><ns03:Address
xmlns:ns03="http://schemas.xmlsoap.org/ws/2004/03/addressing">https://ng
2.ivec.org:8443/wsrf/services/ManagedJobFactoryService</ns03:Address><ns
03:ReferenceProperties
xmlns:ns03="http://schemas.xmlsoap.org/ws/2004/03/addressing"><gram:Reso
urceID
xmlns:gram="http://www.globus.org/namespaces/2004/10/gram/job">Fork</gra
m:ResourceID></ns03:ReferenceProperties></ns08:factoryEndpoint><ns08:exe
cutable>/bin/echo</ns08:executable><ns08:argument>Hello
World!</ns08:argument><ns08:stdout>/tmp/stdout.p2</ns08:stdout><ns08:std
err>/tmp/stderr.p2</ns08:stderr><ns08:count>1</ns08:count></ns08:job></n
s08:multiJob></ns01:createManagedJob></ns00:Body></ns00:Envelope>
----------------------------------------------
------- Comment #1 From 2006-02-16 10:55:23 -------
Can you explain a bit more what is expected/wanted in this bug report? I see in
the help message that those options are ignored for multijobs. I'm not familiar
enough with wsgram multijobs to understand what the issue is with this.

joe
------- Comment #2 From 2006-02-16 11:28:32 -------
Yeah, mlink enlightened me to those options, but I completely disagree with the
reasoning for these options to be ignored for multijobs. It would be very
helpful for users who are trying to run multijobs for globusrun-ws to do the
same thing for each subjob of a multijob when -Sf or -Tf is specified as it does
with each single job.
------- Comment #3 From 2006-02-16 11:31:50 -------
I forgot to add that it would also be possible to simply add a single
stagingCredentialEndpoint element to the multijob since this will be inheritied
by all subjobs. Unfortunately you can't do that with the
transferCredentialEndpoint elements.
------- Comment #4 From 2006-02-16 16:38:21 -------
What might make sense to do is to Allow -Sf and -Tf with multi-jobs, but only
after globusrun-ws has 
verified that all the subjobs in the JDD are going to the same MJFS.  Then
we'll know that the delegated 
cred in the -Sf and -Tf files can be accessed by the subjobs.  Basically, this
is a convenience for the 
submission of a gram job arrary that also requires staging.  I think this is a
lower priority bug/feature 
though and not one to do for 4.0.2.  Note also, that globusrun-ws will perform
the credential delegation 
for a multi-job if just -S -T are specified, so there is a way to submit such a
job.

-Stu
------- Comment #5 From 2006-03-16 16:25:13 -------
Created an attachment (id=881) [details]
Multijob with a fileCleanUp directive in the subjob.
------- Comment #6 From 2006-03-20 16:03:18 -------
I committed a fix to trunk which enables those command line options for
multijobs. Also cleaned up the code so that if the various delegation options
are specified a new delegation will not be done if streaming is to be done.

joe