Bug 4154 - a few gram scheduler tests from the trunk are broken
: a few gram scheduler tests from the trunk are broken
Status: RESOLVED FIXED
: GRAM
wsrf tests
: development
: Macintosh All
: P3 normal
: 4.2
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2006-01-12 14:56 by
Modified: 2006-02-02 13:46 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-01-12 14:56:38
# env

_CONDOR_SCRATCH_DIR=/home/condor/execute/dir_32213
_CONDOR_ANCESTOR_3284=3291:1135198222:4284081408
_CONDOR_ANCESTOR_3291=32213:1137060799:3015312129
_CONDOR_ANCESTOR_32213=32215:1137060814:4026896128
PATH=/home/rynge/software/sed-4.1.4/bin:/home/condor/execute/dir_32213/userdir/install/sbin:/
home/condor/execute/dir_32213/userdir/install/bin:/prereq/apache-ant-1.6.2/bin:/prereq/
java-1.4.2_05/bin:/bin:/usr/bin:/home/condor/execute/dir_32213/userdir
NMI_remote_post=nwo/glue/globus4/build/remote_post.pl
NMI_priority=1
NMI_project=TG
NMI_project_release=1.0
NMI_remote_task=nwo/glue/globus4/build/remote_task.pl
NMI_pre_all=nwo/glue/globus4/build/pre_all.pl
NMI_notify=bacon@mcs.anl.gov
NMI_prereqs_ppc_aix_5.2=tar-1.14, make-3.80, flex-2.5.4a, perl-5.8.5, bison-1.25, vac-6, vacpp-6, 
zlib-1.2.2
NMI_remote_declare_args=--bundle-unit-tests --run-unit-tests
NMI_platforms=x86_fc_3, x86_rh_9, x86_rhas_3, ia64_sles_8, ia64_sles_9, x86_64_rhas_3, x86_fc_4, 
x86_rhas_4, x86_64_rhas_4
NMI_run_type=BUILD
NMI_remote_declare=nwo/glue/globus4/build/remote_declare.pl
NMI_remote_task_args=--tinderbox=http://tinderbox.globus.org/cgi-bin/processmail_builds.cgi --
build-myproxy
NMI_description=Globus linux build for HEAD
NMI_inputs=globus-glue.cvs, globus-src.cvs, iodbc.ftp
NMI_prereqs_sun4u_sol_5.9=tar-1.14, patch-2.5.4, m4-1.4.1, flex-2.5.4a, make-3.80, byacc-1.9, 
gzip-1.2.4, gcc-2.95.3, coreutils-5.2.1, perl-5.8.5
NMI_prereqs=java-1.4.2_05, apache-ant-1.6.2, junit-3.8.1
NMI_component_version=4_0_branch
NMI_component=Globus
NMI_prereqs_sun4u_sol_5.8=tar-1.14, patch-2.5.4, m4-1.4.1, flex-2.5.4a, make-3.80, byacc-1.9, 
gzip-1.2.4, gcc-2.95.3, coreutils-5.2.1, perl-5.8.5
NMI_PLATFORM=x86_fc_3
_NMI_PREREQ_4_ROOT=/prereq/apache-ant-1.6.2
LD_LIBRARY_PATH=/prereq/apache-ant-1.6.2/lib:/prereq/java-1.4.2_05/lib
_NMI_PREREQ_3_ROOT=/prereq/junit-3.8.1
_NMI_STEP_FAILED=remote_task
_NMI_TASKNAME=globus_wsrf_gram_scheduler_test
HOME=/home/bacon
LOGNAME=bacon
JAVA_HOME=/prereq/java-1.4.2_05
GPT_LOCATION=/home/condor/execute/dir_32213/userdir/install
GLOBUS_LOCATION=/home/condor/execute/dir_32213/userdir/install
ANT_HOME=/prereq/apache-ant-1.6.2
CLASSPATH=/prereq/junit-3.8.1/junit.jar

# which java

/prereq/java-1.4.2_05/bin/java

# java -version

java version "1.4.2_05"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_05-b04)
Java HotSpot(TM) Client VM (build 1.4.2_05-b04, mixed mode)

# which ant

/prereq/apache-ant-1.6.2/bin/ant

umask: 22


# ../globus_test/testcred-setup.sh


# . $GLOBUS_LOCATION/etc/globus-user-env.sh && . ../globus_test/testcred-env.sh && ./TESTS.pl

Container Temp Directory: /home/condor/execute/dir_32213/userdir/install/tmp/
gram_scheduler_test_6WlcVn
Skipping "Basic multijob" because:
skip argument matches the scheduler type.
Skipping "Basic global default multijob" because:
skip argument matches the scheduler type.
Logging To submit_test/submit_test_script.log
Will Not Delete Temp Directory /home/condor/execute/dir_32213/userdir/install/tmp/
gram_scheduler_test_Ymy71x
------------------------------------------------
submit_test/submit_test_script

submit001      True                     nmi-build26.cs.wisc.edu:41241Fork    PASS
submit002      False                    nmi-build26.cs.wisc.edu:41241Fork    PASS
submit003      Check Exit Code          nmi-build26.cs.wisc.edu:41241Fork    PASS
submit004      Test multiple arguments (Local)nmi-build26.cs.wisc.edu:41241Fork    PASS
submit005      Local Hello World (Local)nmi-build26.cs.wisc.edu:41241Fork    PASS
submit006      Local Multiple Argument Echo (Local)nmi-build26.cs.wisc.edu:41241Fork    PASS
submit007      Create A File With touch (Local)nmi-build26.cs.wisc.edu:41241Fork    PASS
submit008      Check for existance of "touche" (Local)nmi-build26.cs.wisc.edu:41241Fork    PASS
submit009      Remove The File touche   nmi-build26.cs.wisc.edu:41241Fork    PASS
submit010      JobType multiple (Local) nmi-build26.cs.wisc.edu:41241Fork    PASS
submit201      GLOBUS_USER_HOME substitution (Local)nmi-build26.cs.wisc.edu:41241Fork    PASS
submit202      GLOBUS_USER_NAME substitution (Local)nmi-build26.cs.wisc.edu:41241Fork    FAIL
submit203      GLOBUS_SCRATCH_DIR substitution (Local)nmi-build26.cs.wisc.edu:41241Fork    PASS
submit204      GLOBUS_LOCATION substitution (Local)nmi-build26.cs.wisc.edu:41241Fork    PASS
submit205      Bad Substution           nmi-build26.cs.wisc.edu:41241Fork    FAIL
submit206      relative path to executablenmi-build26.cs.wisc.edu:41241Fork    PASS
submit207      Directory test (Local)   nmi-build26.cs.wisc.edu:41241Fork    PASS
submit208a     Relative directory prep  nmi-build26.cs.wisc.edu:41241Fork    PASS
submit208b     Relative directory test (Local)nmi-build26.cs.wisc.edu:41241Fork    PASS
submit208c     Relative directory post  nmi-build26.cs.wisc.edu:41241Fork    PASS
submit209      Default directory test (Local)nmi-build26.cs.wisc.edu:41241Fork    PASS
submit210      Argument with $ in it    nmi-build26.cs.wisc.edu:41241Fork    PASS
submit211      Argument with back-ticks (`) in itnmi-build26.cs.wisc.edu:41241Fork    PASS
submit212      Argument with single quote (') in itnmi-build26.cs.wisc.edu:41241Fork    PASS
submit213      Argument with double quote (") in itnmi-build26.cs.wisc.edu:41241Fork    PASS
submit214      Argument with question mark (?) in itnmi-build26.cs.wisc.edu:41241Fork    PASS
submit215      Argument with number sign (#) in itnmi-build26.cs.wisc.edu:41241Fork    PASS
submit216      Argument with backslashes (\) in itnmi-build26.cs.wisc.edu:41241Fork    PASS
submit217      Argument with <>s in it  nmi-build26.cs.wisc.edu:41241Fork    PASS
submit218      stdin test               nmi-build26.cs.wisc.edu:41241Fork    PASS
submit219      count test               nmi-build26.cs.wisc.edu:41241Fork    PASS
submit220      environment test         nmi-build26.cs.wisc.edu:41241Fork    PASS
submit221a     Relative directory with substitution prepnmi-build26.cs.wisc.edu:41241Fork    PASS
submit221b     Relative directory with substitution test (Local)nmi-build26.cs.wisc.edu:41241Fork    
PASS
submit221c     Relative directory with substitution postnmi-build26.cs.wisc.edu:41241Fork    PASS
submit222      Existing Env Variable (Local)nmi-build26.cs.wisc.edu:41241Fork    FAIL
submit223      Library Path Test        nmi-build26.cs.wisc.edu:41241Fork    PASS
submit224      Relative stdout (Local)  nmi-build26.cs.wisc.edu:41241Fork    PASS
submit225      Max Time Test            nmi-build26.cs.wisc.edu:41241Fork    PASS
submit226      Max Memory Test          nmi-build26.cs.wisc.edu:41241Fork    PASS
submit227      File Clean Up            nmi-build26.cs.wisc.edu:41241Fork    FAIL
submit402      HoldPending              nmi-build26.cs.wisc.edu:41241Fork    PASS

38 of 42 RSL's Succeeded

Logging To failure_test/failure_test_script.log
Will Not Delete Temp Directory /home/condor/execute/dir_32213/userdir/install/tmp/
gram_scheduler_test_S1LOeR
------------------------------------------------
failure_test/failure_test_script

failure001     Executable does not existnmi-build26.cs.wisc.edu:41241Fork    FAIL
failure002     Executable isn't         nmi-build26.cs.wisc.edu:41241Fork    FAIL
failure003     Directory does not exist nmi-build26.cs.wisc.edu:41241Fork    FAIL
failure004     bad directory permissionsnmi-build26.cs.wisc.edu:41241Fork    FAIL
failure005     Unwritable stdout        nmi-build26.cs.wisc.edu:41241Fork    FAIL
failure006     Unwritable stdout (2)    nmi-build26.cs.wisc.edu:41241Fork    FAIL
failure007     Unwritable stderr        nmi-build26.cs.wisc.edu:41241Fork    FAIL
failure008     Unwritable stderr (2)    nmi-build26.cs.wisc.edu:41241Fork    FAIL
failure009     stdin doesn't exist      nmi-build26.cs.wisc.edu:41241Fork    FAIL
failure010     stdin can't be read      nmi-build26.cs.wisc.edu:41241Fork    FAIL
failure015     Invalid User Id          nmi-build26.cs.wisc.edu:41241Fork    PASS
failure016     condor jobType/scheduler mismatchnmi-build26.cs.wisc.edu:41241Fork    FAIL
failure017     Invalid Hold State       nmi-build26.cs.wisc.edu:41241Fork    FAIL

1 of 13 RSL's Succeeded
------- Comment #1 From 2006-01-20 13:29:56 -------
I can't reproduce the submit202 failure.

The submit205 failure seems to be comming from globusrun-ws. The correct fault
message is being sent, but globusrun-ws chokes on it for some reason. This is
what -dbg shows in lieu of the correct fault:

<ns00:Envelope
xmlns:ns00="http://schemas.xmlsoap.org/soap/envelope/"><ns00:Header><ns01:MessageID
xmlns:ns01="http://schemas.xmlsoap.org/ws/2004/03/addressing">uuid:b606cd70-89ea-11da-89da-000d61215ff0</ns01:MessageID><ns01:To
xmlns:ns01="http://schemas.xmlsoap.org/ws/2004/03/addressing">http://schemas.xmlsoap.org/ws/2004/03/addressing/role/anonymous</ns01:To><ns01:Action
xmlns:ns01="http://schemas.xmlsoap.org/ws/2004/03/addressing">http://schemas.xmlsoap.org/ws/2004/03/addressing/fault</ns01:Action><ns01:RelatesTo
xmlns:ns01="http://schemas.xmlsoap.org/ws/2004/03/addressing">uuid:b5f86b40-89ea-11da-8ce7-86ce422b5d79</ns01:RelatesTo></ns00:Header><ns00:Body><ns00:Fault><ns00:faultcode>Client</ns00:faultcode><ns00:faultstring>an
unknown error occurred
</ns00:faultstring></ns00:Fault></ns00:Body></ns00:Envelope>

It then hangs the client until the automatic polling engages. I'll reassign this
bug to Joe once I'm finished fixing the other problems.

The submit222 failure was due to the fact that environment element overriddes
were broken. I fixed this by making JDD variables for all environment variables
and only setting well-known JDD variables if they haven't already been set.

The submit227 failure was due to it not being skipped since it's StagingOnly
directive was incorrect. I fixed the directive so this test should not be run
without staging enabled anymore.

The fault* failures appear to be due to the same problem as submit205.
------- Comment #2 From 2006-02-02 12:21:31 -------
I committed some serialization and deserialization fixes in c ws core which fix
most of the problems (in cgen and globus_ws_messaging). After doing so, the
failures are reduced to submit222 and failure017. 

I'm not sure if submit222 is a legit test (it is assuming it can override an rsl
substitution by setting an environment variable)

The failure017 test fails because it contains an invalid input (which the c
deserializer now catches). If there are some job states which would be legal job
states but illegal for holds, we can update that test, otherwise, we should
remove it.

joe
------- Comment #3 From 2006-02-02 13:46:48 -------
I see that Peter changed the server code to make submit222 pass. I still have
doubts about that test, but whatever. The other test case is now fixed as well,
so they can all pass.

joe