Bug 4149 - env GLOBUS_HOSTNAME=invalid globus-gass-server abort
: env GLOBUS_HOSTNAME=invalid globus-gass-server abort
Status: VERIFIED FIXED
: GridFTP
GASS
: 4.0.1
: PC Linux
: P3 normal
: 4.0.2
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2006-01-09 20:57 by
Modified: 2006-08-16 16:27 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-01-09 20:57:52
Invalid GLOBUS_HOSTNAME causes globus-gass-server abort.
globus-gass-server do not error and return safely.

I don't know this is the valid usage, changing GLOBUS_HOSTNAME.
But, I think globus-gass-server should return by error, or 
ignore the value of GLOBUS_HOSTNAME.

In my application, I prefer globus_gass_server_ez_init() error and return
if the invalid GLOBUS_HOSTNAME was given.
  (Our application uses GASS for Pre-WS GRAM support, our older usage of GT.
   Our application do not use GASS for WS GRAM support though.)
I don't need my application abort().

This problem occurred on GT4.0.1 and GT3.2.
This problem did not occurred on GT2.4.3.

This problem occurred on Linux x86, IA64.
This problem did not occurred on Solaris.

I'm setting environment variable MALLOC_CHECK_=2 on Linux.

$ export GLOBUS_LOCATION=/usr/local/GT/gt-2.4.3
$ . $GLOBUS_LOCATION/etc/globus-user-env.sh
$ env GLOBUS_HOSTNAME=invalid globus-gass-server
https://invalid:33365

$ export GLOBUS_LOCATION=/usr/local/GT/gt32-gcc3.2.2
$ . $GLOBUS_LOCATION/etc/globus-user-env.sh
$ env GLOBUS_HOSTNAME=invalid globus-gass-server
Aborted (core dumped)
$ gdb `type -p globus-gass-server` core.13008
warning: core file may not match specified executable file.
Core was generated by `globus-gass-server'.
Program terminated with signal 6, Aborted.
#0  0xffffe002 in ?? ()
(gdb) where
#0  0xffffe002 in ?? ()
#1  0x42027431 in raise () from /lib/tls/libc.so.6
#2  0x42028a73 in abort () from /lib/tls/libc.so.6
#3  0x42075e09 in free_check () from /lib/tls/libc.so.6
#4  0x42073485 in free () from /lib/tls/libc.so.6
#5  0x4002bc7a in globus_gass_transfer_create_listener (listener=0xbffff4d4,
    attr=0xbffff4d0, scheme=0x8049dd2 "https")
    at globus_gass_transfer_server.c:129
#6  0x400187c7 in globus_gass_server_ez_init (listener=0xbffff4d4,
    attr=0xbffff4d0, scheme=0x8049dd2 "https", reqattr=0x805d400, options=127,
    callback=0) at globus_gass_server_ez.c:187
#7  0x08049528 in main (argc=1, argv=0xbffff554) at globus_gass_server.c:335
(gdb) quit
$
$ export GLOBUS_LOCATION=/home/someone/gt4
$ . $GLOBUS_LOCATION/etc/globus-user-env.sh
$ env GLOBUS_HOSTNAME=invalid globus-gass-server
Aborted (core dumped)
$ gdb `type -p globus-gass-server` core.13043
warning: core file may not match specified executable file.
Core was generated by `globus-gass-server'.
Program terminated with signal 6, Aborted.
#0  0xffffe002 in ?? ()
(gdb) where
#0  0xffffe002 in ?? ()
#1  0x42027431 in raise () from /lib/tls/libc.so.6
#2  0x42028a73 in abort () from /lib/tls/libc.so.6
#3  0x42075e09 in free_check () from /lib/tls/libc.so.6
#4  0x42073485 in free () from /lib/tls/libc.so.6
#5  0x4002bc6a in globus_gass_transfer_create_listener (listener=0xbfffeb84,
    attr=0xbfffeb80, scheme=0x8049dd2 "https")
    at globus_gass_transfer_server.c:140
#6  0x400187df in globus_gass_server_ez_init (listener=0xbfffeb84,
    attr=0xbfffeb80, scheme=0x8049dd2 "https", reqattr=0x805eef8, options=127,
    callback=0) at globus_gass_server_ez.c:198
#7  0x08049520 in main (argc=1, argv=0xbfffec04) at globus_gass_server.c:346
(gdb)
------- Comment #1 From 2006-01-10 10:10:20 -------
Fix committed to CVS. An update package is linked off of
http://www.globus.org/toolkit/advisories.html
------- Comment #2 From 2006-01-11 05:08:54 -------
thanks.
verified.

$ env GLOBUS_HOSTNAME=invalid globus-gass-server
Error: Cannot listen on port
$ 
------- Comment #3 From 2006-08-16 16:27:43 -------
*** Bug 4649 has been marked as a duplicate of this bug. ***