Bug 3944 - RFT messages on missing input file
: RFT messages on missing input file
Status: RESOLVED FIXED
: RFT
RFT
: 4.0.1
: PC Windows XP
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-11-28 15:17 by
Modified: 2005-12-01 15:06 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-11-28 15:17:24
My RFT config file requests two file transfers. If both input files exist, the
transfer ends with a feel-good summary:

    All Transfers are completed

If I delete one input file, this is the output:

[jem@risk rft]$ rft -h risk.usa.hp.com -f jt.xfr  -file xx
Number of transfers in this request: 2
Subscribed for overall status
Termination time to set: 60 minutes

 Overall status of transfer:
Finished/Active/Failed/Retrying/Pending
0/1/0/0/1

 Overall status of transfer:
Finished/Active/Failed/Retrying/Pending
1/0/0/0/1

 Overall status of transfer:
Finished/Active/Failed/Retrying/Pending
1/1/0/0/0
Error:Error updating Permissions of a file/tmp/jt2.in [Caused by: Server refused
performing the request. Custom message: Server refused MLST command (error code
1) [Nested exception message:  Custom message: Unexpected reply: 500-Command
failed : System error in stat: No such file or directory
500-A system call failed: No such file or directory
500 End.]]

 Overall status of transfer:
Finished/Active/Failed/Retrying/Pending
1/0/1/0/0
Error:Error updating Permissions of a file/tmp/jt2.in [Caused by: Server refused
performing the request. Custom message: Server refused MLST command (error code
1) [Nested exception message:  Custom message: Unexpected reply: 500-Command
failed : System error in stat: No such file or directory
500-A system call failed: No such file or directory
500 End.]]

1) The error message needs to be improved to catch the condition and simply say
that the file is missing.  It's good that this doesn't result in a full stack
trace, but it's still more verbose than needed - e.g. the user isn't concerned
with the initial part about permissions.  It would be useful to have a
"-verbose" or "-debug" flag to give the additional info.

2) The message formatting needs some attention: the file path merges with the
word "file" preceding it, and there are other issues (trivial, but still worth
fixing).

3) The command then hangs, which I believe is the subject of another report and
is probably already fixed, but it's not clear that if it had terminated properly
it would have reported the successful transfer of the other file.
------- Comment #1 From 2005-12-01 15:06:20 -------
1. I cannot add new command line options as it would be considered as a
interface change. However it is 
added in the trunk and will be released in 4.2
2. should be fixed now
3. should be fixed now