Bug 3833 - Problems with rft-delete
: Problems with rft-delete
Status: RESOLVED FIXED
: RFT
RFT
: 4.0.1
: Macintosh All
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-10-20 13:14 by
Modified: 2005-12-01 15:41 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-10-20 13:14:07
[kut@omii02 RFT]$ rft-delete -h omii02.jinr.ru -r 8080 -m msg -f delete.xfr
creating a transfer
http://omii02.jinr.ru:8080/wsrf/services/ReliableFileTransferFactoryService  http://omii02.jinr.ru:
8080/wsrf/services/ReliableFileTransferService
Exception in thread "main" Error during startup processing. Caused by AxisFault
faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.userException
faultSubcode:
faultString: java.rmi.RemoteException: Unable to create RFT resource; nested exception is:
       java.lang.NullPointerException
faultActor:
faultNode:
faultDetail:
       {http://xml.apache.org/axis/}stackTrace:java.rmi.RemoteException: Unable to create RFT resource; 
nested exception is:
       java.lang.NullPointerException
       at 
org.globus.transfer.reliable.service.factory.ReliableFileTransferFactoryService.createReliableFileTransfer
(ReliableFileTransferFactoryService.java:234)
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
       at java.lang.reflect.Method.invoke(Method.java:585)
       at org.apache.axis.providers.java.RPCProvider.invokeMethod(RPCProvider.java:384)
       at org.globus.axis.providers.RPCProvider.invokeMethodSub(RPCProvider.java:107)
       at org.globus.axis.providers.PrivilegedInvokeMethodAction.run(PrivilegedInvokeMethodAction.java:
42)
       at java.security.AccessController.doPrivileged(Native Method)
       at javax.security.auth.Subject.doAs(Subject.java:396)
       at org.globus.gsi.jaas.GlobusSubject.runAs(GlobusSubject.java:55)
       at org.globus.gsi.jaas.JaasSubject.doAs(JaasSubject.java:90)
       at org.globus.axis.providers.RPCProvider.invokeMethod(RPCProvider.java:97)
       at org.apache.axis.providers.java.RPCProvider.processMessage(RPCProvider.java:281)
       at org.apache.axis.providers.java.JavaProvider.invoke(JavaProvider.java:319)
       at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
       at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
       at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
       at org.apache.axis.handlers.soap.SOAPService.invoke(SOAPService.java:450)
       at org.apache.axis.server.AxisServer.invoke(AxisServer.java:285)
       at org.globus.wsrf.container.ServiceThread.doPost(ServiceThread.java:677)
       at org.globus.wsrf.container.ServiceThread.process(ServiceThread.java:398)
       at org.globus.wsrf.container.ServiceThread.run(ServiceThread.java:302)
Caused by: java.lang.NullPointerException
       at org.globus.transfer.reliable.service.database.ReliableFileTransferDbAdapter.storeDelete
(ReliableFileTransferDbAdapter.java:465)
       at org.globus.transfer.reliable.service.database.ReliableFileTransferDbAdapter.storeDeleteRequest
(ReliableFileTransferDbAdapter.java:295)
       at org.globus.transfer.reliable.service.ReliableFileTransferResource.<init>
(ReliableFileTransferResource.java:201)
       at org.globus.transfer.reliable.service.ReliableFileTransferHome.create
(ReliableFileTransferHome.java:120)
       at 
org.globus.transfer.reliable.service.factory.ReliableFileTransferFactoryService.createReliableFileTransfer
(ReliableFileTransferFactoryService.java:224)
       ... 22 more

       {http://xml.apache.org/axis/}hostname:omii02.jinr.ru
------- Comment #1 From 2005-12-01 15:41:20 -------
Fixed in branch. Let me know if you see any more issues.