Bug 3770 - Incorrect GPT metadata breaks VDT builds
: Incorrect GPT metadata breaks VDT builds
Status: RESOLVED FIXED
: GRAM
wsrf scheduler interface
: 4.0.1
: PC Linux
: P3 normal
: 4.0.2
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-09-21 17:22 by
Modified: 2006-04-07 16:25 (History)


Attachments
Fixes GPT metadata for Globus SEG (2.00 KB, patch)
2005-09-22 13:30, Alain Roy
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-09-21 17:22:57
Hi,

In the VDT, we build Globus with 'make' but no 'make install'. Then we bundle it
with GPT and further manipulate it until we are ready to distribute it. We've
been having problems with the bundling step. gpt-bundle tells us:

ERROR: The following packages are missing
Package globus_wsrf_gram_service_java_setup_condor-noflavor-pgm is missing
Runtime-globus_scheduler_event_generator_condor-ANY-pgm

ERROR: The following packages are missing
Package globus_wsrf_gram_service_java_setup_pbs-noflavor-pgm is missing
Runtime-globus_scheduler_event_generator_pbs-ANY-pgm

ERROR: The following packages are missing
Package globus_wsrf_gram_service_java_setup_lsf-noflavor-pgm is missing
Runtime-globus_scheduler_event_generator_lsf-ANY-pgm

Died at /home/condor/execute/dir_20599/userdir/install/sbin/gpt-bundle line
665.

After some debugging and some assistance from Eric Blau and Joe Bester, it seems
that the problem is that the GPT metadata for
globus_wsrf_gram_service_java_setup_condor says that it depends on a pgm package
from globus_scheduler_event_generator_condor. To be specific, it says:

<Source_Dependencies Type="pgm_runtime">

<Dependency Name="globus_scheduler_event_generator_condor" Package="pgm">
    <Version>
      <Simple_Version Major="0"/>
    </Version>
</Dependency>

</Source_Dependencies>

But the globus_scheduler_event_generator_condor has no pgm package, only rtl and
dev pacakges. 

My best guess is that this should be changed to depend on the rtl package, and
not the pgm pacakage. 

This exact same error happens for PBS and LSF. 

My understanding is that you wonderful Globus folks will commit a fix for this
bug shortly, but Stu and I agreed that it would be useful to have a bug report
for various reasons. 

Thanks,
-alain
------- Comment #1 From 2005-09-22 13:30:39 -------
Created an attachment (id=706) [details]
Fixes GPT metadata for Globus SEG

I tested this patch, and it seems to work. It's not obvious to me if there is a
better patch or not, but I know it worked around my problem. 

Thanks!
------- Comment #2 From 2005-10-05 15:51:12 -------
Committed to branch and trunk.
------- Comment #3 From 2005-10-05 16:00:25 -------
Thanks, I appreciate it!