Bug 3769 - -cd wont create more than one level of directories
: -cd wont create more than one level of directories
Status: RESOLVED FIXED
: GridFTP
GridFTP
: unspecified
: PC Linux
: P3 normal
: 4.0.2
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-09-21 10:25 by
Modified: 2006-04-18 14:14 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-09-21 10:25:08
The -cd (create directory) option on globus-url-copy will create the directory
if it is immediately under an existing directory, but not if there is more than
one layer missing in the tree. 

Example (/tmp exists, but /tmp/a does not, nor does /tmp/a/b):

allcock@gridftp:~> guc -p 1 -cd file:///home/allcock/junk
gsiftp://localhost/tmp/a/b/

error: globus_ftp_client: the server responded with an error
500 500-Command failed. : globus_l_gfs_file_open failed.
500-globus_xio: Unable to open file /tmp/a/b/junk
500-globus_xio: System error in open: Not a directory
500-globus_xio: A system call failed: Not a directory
500 End.

allcock@gridftp:~> guc -p 1 -cd file:///home/allcock/junk gsiftp://localhost/tmp/b/
allcock@gridftp:~> guc -p 1 -cd file:///home/allcock/junk
gsiftp://localhost/tmp/b/a/
allcock@gridftp:~>
------- Comment #1 From 2005-11-28 17:58:01 -------
*** Bug 3956 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2005-11-28 18:10:23 -------
Could you make this bug as major as we need this feature. Can someone please 
push the priority on fixing this. I see that it has not even been assigned 
since september
------- Comment #3 From 2005-12-01 22:53:44 -------
This is fixed and committed to CVS.  An update package to 4.0.1 will be 
available at http://www.globus.org/toolkit/advisories.html shortly.