Bug 3662 - rft command - fails with NegativeArraySizeException
: rft command - fails with NegativeArraySizeException
Status: RESOLVED FIXED
: RFT
RFT
: 4.0.1
: All All
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-08-17 07:50 by
Modified: 2005-08-22 10:05 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-08-17 07:50:44
Contents of transferTest.xfr are:
gsiftp://localhost:2811/tmp/rftTestTOM.tmp
gsiftp://localhost:2811/tmp/rftTestTOM_Done.tmp

I ran this command: rft -p 8443 -f transferTest.xfr 
and got this error:

Exception in thread "main" Error during startup processing. Caused by
java.lang.NegativeArraySizeException: 
        at
org.globus.transfer.reliable.client.ReliableFileTransferClient.getTransfer(ReliableFileTransferClient.java:89)
        at
org.globus.transfer.reliable.client.ReliableFileTransferClient.main(ReliableFileTransferClient.java:171)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:85)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:58)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:60)
        at java.lang.reflect.Method.invoke(Method.java:391)
        at org.globus.bootstrap.BootstrapBase.launch(BootstrapBase.java:95)
        at org.globus.bootstrap.Bootstrap.main(Bootstrap.java:37)


At a minimum the code in ReliableFileTransferClient needs some protection like 
if (transferCount < 0) { System.err.println("invalid transfer file format") }
------- Comment #1 From 2005-08-22 10:05:00 -------
Fix comitted to branch.