Bug 3634 - Problem with RFT IDs when using MySQL database
: Problem with RFT IDs when using MySQL database
Status: RESOLVED FIXED
: RFT
RFT
: 4.0.1
: PC Linux
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-08-11 04:00 by
Modified: 2005-08-22 11:04 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-08-11 04:00:02
MySQL version 3.23.58 and GT4.0.1 was used. RFT database was set up with
script:
$GLOBUS_LOCATION/share/globus_wsrf_rft/rft_schema_mysql.sql 
Modifications described in Bug 3633 were aplied. 

First transfer achieved with following command went fine:
$ globusrun-ws -F host.name -s -c /bin/hostname

All the following requests failed with message:
Unable to create RFT resource
Error inserting records into database
. Caused by
java.sql.SQLException: Invalid argument value,  message from server: "Duplicate
entry '0' for key 1"

In the database, both requestid and transferid table have value 1:
mysql> select * from transferid;
+-------------+
| transfer_id |
+-------------+
|           1 |
+-------------+
1 row in set (0.00 sec)

mysql> select * from requestid;
+------------+
| request_id |
+------------+
|          1 |
+------------+

Tables request and transfer have one entry. ID of both entries in request and
transfer tables is set to 0:
mysql> select id from request;
+----+
| id |
+----+
|  0 |
+----+

mysql> select id,request_id from transfer;
+----+------------+
| id | request_id |
+----+------------+
|  0 |          0 |
+----+------------+
------- Comment #1 From 2005-08-19 11:15:43 -------
I just ran all the tests again with mysql version 3.23.58 and it works fine for
me. I don't see this error.
------- Comment #2 From 2005-08-21 12:30:02 -------
Any update on this ?
------- Comment #3 From 2005-08-21 13:28:16 -------
I found the cause of this problem. In the first case I used MySQL JDBC version
3.0.8. Now I installed version 3.1.10 and it is working fine. I also tested
again with 3.0.8 and I got the same error.
------- Comment #4 From 2005-08-22 09:48:07 -------
I will add documentation citing this. 
------- Comment #5 From 2005-08-22 11:04:45 -------
Added documentation