Bug 3556 - globusrun-ws header deserialization error on destroy
: globusrun-ws header deserialization error on destroy
Status: RESOLVED FIXED
: GRAM
wsrf gram clients
: 4.0.0
: Macintosh MacOS
: P3 critical
: 4.0.1
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-07-11 18:48 by
Modified: 2005-07-13 10:43 (History)


Attachments
fault.txt (2.88 KB, text/plain)
2005-07-13 08:17, Joe Bester
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-07-11 18:48:44
I have confirmed a problem that Nick is having on his G5 (i.e. Linux seems
fine)
whereby globusrun-ws complains on destroy about header deserialization as
follows:

w005.z208176063.chi-il.dsl.cnc.net% globusrun-ws -submit -self -f test.xml
Submitting job...Done.
Job ID: uuid:210e7d52-f265-11d9-91cd-000a95a7fc1e
Termination time: 07/12/2005 23:40 GMT
Current job state: Active
Current job state: CleanUp
Current job state: Done
Destroying job...Failed.
globusrun-ws: Unable to destroy job: Error destroying job
globus_soap_message_module: Failed receiving response
ManagedJobPortType_Destroy.
globus_soap_message_module: Deserialization of
{http://schemas.xmlsoap.org/soap/envelope/}Header failed.
------- Comment #1 From 2005-07-13 08:17:08 -------
Created an attachment (id=655) [details]
fault.txt

Attaching the fault message which Java is sending as a response to the destroy
message. Any idea why it thinks there is a problem? Otherwise, it looks like
bug #2437.

joe
------- Comment #2 From 2005-07-13 10:43:34 -------
Found the problem, bad string comparison in globus_i_kill was making
globusrun-ws try to use ws-secure message when destroying the job. Fix is
committed to trunk and gt4 branch.