Bug 3545 - globus-start-container Failed to start container
: globus-start-container Failed to start container
Status: RESOLVED FIXED
: Java WS Core
globus_wsrf_core
: 4.0.0
: PC Linux
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-07-07 14:32 by
Modified: 2005-07-12 09:30 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-07-07 14:32:42
I've tried using both the java that came with Suse 9.1, j2sdk1.4.2_04 and
jdk1.5.0_01

globus@gridlap10:/opt/Globus/bin> ./globus-start-container
Failed to start container:  [Caused by: java.lang.NullPointerException]
globus@gridlap10:/opt/Globus/bin> ./globus-start-container -nosec
Failed to start container:  [Caused by: java.lang.NullPointerException]
globus@gridlap10:/opt/Globus/bin> ./globus-start-container -nosec -debug
. Caused by java.lang.NullPointerException
        at
org.globus.usage.packets.IPTimeMonitorPacket.packCustomFields(IPTimeMonitorPacket.java:62)
        at
org.globus.wsrf.container.usage.ContainerUsageBasePacket.packCustomFields(ContainerUsageBasePacket.java:71)
        at
org.globus.usage.packets.UsageMonitorPacket.toByteArray(UsageMonitorPacket.java:85)
        at
org.globus.usage.packets.UsageMonitorPacket.sendPacket(UsageMonitorPacket.java:105)
        at
org.globus.usage.packets.UsageMonitorPacket.sendPacket(UsageMonitorPacket.java:164)
        at
org.globus.usage.packets.UsageMonitorPacket.sendPacket(UsageMonitorPacket.java:219)
        at
org.globus.wsrf.container.UsageConfig.sendStopPacket(UsageConfig.java:147)
        at org.globus.wsrf.container.ServiceManager.stop(ServiceManager.java:236)
        at
org.globus.wsrf.container.ServiceDispatcher.stop(ServiceDispatcher.java:263)
        at
org.globus.wsrf.container.ServiceContainer.close(ServiceContainer.java:280)
        at
org.globus.wsrf.container.ServiceContainer.<init>(ServiceContainer.java:207)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at
sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
        at
sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
        at java.lang.reflect.Constructor.newInstance(Constructor.java:274)
        at
org.globus.wsrf.container.ServiceContainer.createContainer(ServiceContainer.java:135)
        at
org.globus.wsrf.container.ServiceContainer.main(ServiceContainer.java:397)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:324)
        at org.globus.bootstrap.BootstrapBase.launch(BootstrapBase.java:95)
        at org.globus.bootstrap.Bootstrap.main(Bootstrap.java:37)
globus@gridlap10:/opt/Globus/bin> echo $GLOBUS_LOCATION
/opt/Globus/
globus@gridlap10:/opt/Globus/bin> cd ..
globus@gridlap10:/opt/Globus> ls
bin                         doc       GLOBUS_LICENSE                      
include  log4j.properties  setup  tmp
client-config.wsdd          endorsed  gt4.0.0-all-source-installer         lib 
    man               share  var
container-log4j.properties  etc       gt4.0.0-all-source-installer.tar.gz 
libexec  sbin              test
globus@gridlap10:/opt/Globus>
------- Comment #1 From 2005-07-07 14:41:16 -------
This is caused when the container can't determine the host name of your 
machine. Check your setup. Also, try setting GLOBUS_HOSTNAME environment 
property before starting the container. 

The code in cvs was already fixed to handle this case correctly anyway. 
------- Comment #2 From 2005-07-12 09:30:26 -------
*** Bug 3557 has been marked as a duplicate of this bug. ***