Bug 3459 - RFT/GRAM cleanup failure
: RFT/GRAM cleanup failure
Status: RESOLVED
: RFT
RFT
: 4.0.1
: PC Linux
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-06-08 13:45 by
Modified: 2005-06-08 14:03 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-06-08 13:45:02
This is from globus_4_0_branch:

[rynge@devrandom patches]$ globusrun-ws -submit -S -s -F nimrod.isi.edu:5000
-c/bin/hostname
Delegating user credentials...Done.
Submitting job...Done.
Job ID: uuid:16b7a838-d84d-11d9-bbeb-0008744f939a
Termination time: 06/09/2005 18:42 GMT
Current job state: Active
Current job state: CleanUp-Hold
nimrod.isi.edu
Current job state: CleanUp
Current job state: Failed
Destroying job...Done.
Cleaning up any delegated credentials...Done.
globusrun-ws: Job failed: Staging error for RSL element fileCleanUp.




java.rmi.RemoteException: Unable to create RFT resource; nested exception is:
        org.apache.commons.dbcp.DbcpException: Connection refused. Check that
the hostname and port are correct and that the postmaster is accepting TCP/IP
connections.




org.oasis.wsrf.faults.BaseFaultType



org.apache.axis.AxisFault




org.globus.exec.generated.StagingFaultType





Container log shows:


2005-06-08 11:42:55,923 ERROR factory.TotalNumberOfBytesTransferred [Thread-11,g
etTotalNumberOfBytesTransferred:55] Error retrieving data from database for id:
 "{0}"
Error retrieving data from database for id:
 "{0}"
. Caused by
An I/O error has occured while flushing the output - Exception: java.net.SocketE
xception: Broken pipe
Stack Trace:

java.net.SocketException: Broken pipe
        at java.net.SocketOutputStream.socketWrite0(Native Method)
        at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:92)
        at java.net.SocketOutputStream.write(SocketOutputStream.java:136)
        at java.io.BufferedOutputStream.flushBuffer(BufferedOutputStream.java:66
)
        at java.io.BufferedOutputStream.flush(BufferedOutputStream.java:124)
        at org.postgresql.PG_Stream.flush(PG_Stream.java:352)
        at org.postgresql.core.QueryExecutor.sendQuery(QueryExecutor.java:154)
        at org.postgresql.core.QueryExecutor.execute(QueryExecutor.java:70)
------- Comment #1 From 2005-06-08 14:03:08 -------
Bah, forgot to change the staging port to the non-standard port I was using.