Bug 3420 - CAMPAIGN: WS-GRAM Command-line Client Tools
: CAMPAIGN: WS-GRAM Command-line Client Tools
Status: RESOLVED FIXED
: GRAM
wsrf gram clients
: development
: PC Linux
: P3 contribution
: 4.2
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-05-27 14:50 by
Modified: 2005-09-23 15:40 (History)


Attachments
perl script wrapper (13.15 KB, text/plain)
2005-05-27 14:51, Jens-S. Vöckler
Details
here it goes (13.14 KB, text/plain)
2005-05-27 14:53, Jens-S. Vöckler
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-05-27 14:50:57
I've written a globus-job-run like wrapper around globusrun-ws which is mostly
argument compatible to pre-WS globus-job-run. I'll attach it next. Since the
last version I've fixed the UUID generator.
------- Comment #1 From 2005-05-27 14:51:47 -------
Created an attachment (id=626) [details]
perl script wrapper
------- Comment #2 From 2005-05-27 14:53:15 -------
Created an attachment (id=627) [details]
here it goes
------- Comment #3 From 2005-07-12 16:46:38 -------
*** Bug 3079 has been marked as a duplicate of this bug. ***
------- Comment #4 From 2005-07-18 18:48:27 -------
I'm turning this bug into a campaign tracking bug.  Here is the campaign
definition:

-------------------------------------------------------------------------

Title: WS-GRAM Command-line Client Tools


Projects:


Technologies:    Globus Resource Allocation Manager (GRAM)


Definition:

Users have been asking for an equivalent of globus-job-run, globus-job-submit,
globus-job-get-output, and globus-job-clean for WS-GRAM.  These were script
wrappers around globusrun, and this campaign deals with creating similar script
wrappers around globusrun-ws with as near backwards compatibility (in terms of
arguments) as possible.  Jens Voeckler has submitted an enhancement request
(bug
#3420) with an attached script that does basic globus-job-run functionality for
WS-GRAM.  This script should be leveraged as a starting point to minimize
effort.


Deliverables:

1) The following scripts shall be created:
    1a) globus-job-run-ws
    1b) globus-job-submit-ws
    1c) globus-job-get-output-ws
    1d) globus-job-clean-ws
2) New globus_wsrf_gram_client_tools GPT package
3) New globus_wsrf_gram_client_tools_test GPT package with:
    3a) unit tests for correct command line option parsing/job 
    description creation, and
    3b) unit tests for correct globusrun-ws and globus-url-copy invocation
4) Command line client documentation for all of the scripts

Tasks:

1) Add support for multijob requests in globus-job-run-ws
2) Conform arguments of globus-job-run-ws to globus-job-run as best as possible
3) Add switches in globus-job-run-ws for acting as globus-job-submit-ws
(similar
to globus-job-submit).
4) Create globus-job-get-output-ws using globus-url-copy and job stdout/err
Resource Properties
5) Create globus-job-clean-ws using globusrun-ws to kill the job (fileCleanUp
and CleanUp hold directives added to job description document in task #3)
6) Create globus_wsrf_gram_client_tools GPT package build and metadata files
7) Create unit tests for verifying that a correct job descriptions are
generated
for all of the options of each script
8) Create unit tests for verifying that all globusrun-ws and globus-url-copy
commands work for all of the options of each script
9) Add pages to the command line client section of the WS-GRAM documentation
for
each of the scripts

Time Estimate:

7 days
------- Comment #5 From 2005-07-18 18:55:32 -------
Deliverables 1a and 1b are almost done.  I have both single and multijob markup
done except for the default option markup for multijobs.  I haven't tested
either *-run or *-submit in terms of functionality (just used the -dumpjdd
option).  The evolving package can be found in ws-gram/client/c/tools/source. 
The build files are working, so if anyone wants to take a peak they should be
able to use gpt-build to get both globus-job-run-ws and globus-job-submit-ws
deployed.
------- Comment #6 From 2005-07-19 17:24:53 -------
Tasks 1-3 are done (deliverables 1a and 1b).  Will start on the other scripts
tomorrow.
------- Comment #7 From 2005-07-21 17:32:19 -------
Completed task 5 (deliverable 1d).
------- Comment #8 From 2005-07-21 19:16:56 -------
Got a basic globus-job-get-output-ws working that just prints the stdout and
stderr to the screen.  Need to add options for saving to a file.
------- Comment #9 From 2005-08-08 15:37:46 -------
This campaign has been delayed because of 4.0.1 release activities.

Looking at globus-job-get-output, I've changed globus-job-get-output-ws to
conform more closely to it.  This means no saving to files and fetching of only
stdout OR stderr (not both).  Changes have been comitted.

Deliverables 1 and 2 (tasks 1-6) are done.  Just need to add tests and
documentation.
------- Comment #10 From 2005-08-15 13:19:40 -------
Got a little delayed again last week by bugs that needed fixing.  The test
harness is mostly done.  The actual test cases should follow soon afterwards.  I
will be off the rest of this week, so no progress will be made then.
------- Comment #11 From 2005-08-24 12:58:01 -------
The tools need authz options.  The tests won't work with personal containers
without them.  It's also a reasonable feature to have.  Working on it now.
------- Comment #12 From 2005-08-24 18:59:22 -------
Turns out that making tests work with a personal mode container is a pain, so I
just made the test harness startup a container using the default GT settings and
assume host authz for now.

I finished adding the command tests but haven't run them since my GT install is
messed up.  I'm rebuilding overnight and will make sure they run tomorrow.  I
should also be able to add the job description tests tomorrow.
------- Comment #13 From 2005-08-27 12:28:33 -------
Finished the command doc:

http://www-unix.globus.org/toolkit/docs/4.0/execution/wsgram/WS_GRAM_Command-line_Frag.html

This campaign can be closed.
------- Comment #14 From 2005-09-23 15:40:53 -------
The update package never got put up, so I did this just now:

http://www-unix.globus.org/toolkit/downloads/development/