Bug 3371 - cas-group-admin user delete fails
: cas-group-admin user delete fails
Status: RESOLVED FIXED
: CAS/SAML utilities
CAS
: development
: PC Linux
: P3 normal
: 4.2
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-05-17 10:06 by
Modified: 2006-10-16 13:11 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-05-17 10:06:00
Hello.

I am exercising the CAS functions and tried to add and delete users from a group.

I can add a user to a group, but when I try the cas-group-admin user delete
function I get an error:

[globus@ds01 bin]$ cas-group-admin user create group00 group00
Completed successfully
[globus@ds01 bin]$ cas-group-admin user delete group00 
Delete group "group00" failed Error deleting "user group" "ERROR: 
usergp_gp_reference referential integrity violation - key in user_group_table
still referenced from user_group_entry
" [Caused by: ERROR:  usergp_gp_reference referential integrity violation - key
in user_group_table still referenced from user_group_entry
]

Any suggestions?

Ramon Williamson
------- Comment #1 From 2005-07-19 14:53:04 -------
In this case all rights on the group are being given to the group created. This 
would add the current user to the group. Deletion is an issue with group 
memeber ship and rights stored for this user. I have altered code to disallow 
this. Since we have an idea of super user, a group created at bootstrap that 
does not need another user group to have grant all on it, it should be feasible 
to create other user groups off that. Fixes have been committed to trunk.
------- Comment #2 From 2006-04-06 15:48:13 -------
Would it be possible to backport these fixes to 'globus_4_0_branch'?

IMO it would be really useful for CAS users.
------- Comment #3 From 2006-04-11 13:42:46 -------
I am reopening this bug. I'll look at the fixes to see if they can be
backported.
------- Comment #4 From 2006-10-16 13:11:53 -------
Fixes have been committed to 4.0. branch