Bug 3318 - globusrun-ws problem
: globusrun-ws problem
Status: RESOLVED FIXED
: C WS Core
Serialization/Transport
: 4.0.0
: Sun Solaris
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-05-10 04:25 by
Modified: 2005-07-06 12:47 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-05-10 04:25:47
The following bugs were detected on Solaris. 


$ cat test.xml 
<job>
  <executable>/bin/echo</executable>
  <argument>Hello Globus</argument>
  <stdout>/home/kawamura/stdout</stdout>
  <stderr>/home/kawamura/stderr</stderr>
</job>
$ globusrun-ws -submit -f test.xml 
Submitting job...Failed.
globusrun-ws: Error submitting job
globus_soap_message_module: Deserialization of
{http://www.w3.org/2001/XMLSchema}dateTime failed.
globus_soap_message_module: Deserialization of
{http://www.globus.org/namespaces/2004/10/gram/job}NewTerminationTime failed.
globus_soap_message_module: Failed deserialization of content
"2005-05-11T09:12:42.000Z" {http://www.w3.org/2001/XMLSchema}dateTime type.
$
------- Comment #1 From 2005-05-10 07:40:57 -------
Please run the globusrun-ws command with the environment variable
GLOBUS_SOAP_MESSAGE_DEBUG set to MESSAGES like this:

env GLOBUS_SOAP_MESSAGE_DEBUG=MESSAGES globusrun-ws -submit -f test.xml 

and send us the output?

Thanks.
------- Comment #2 From 2005-05-12 20:34:39 -------
The debugging message was not output.

$ env GLOBUS_SOAP_MESSAGE_DEBUG=MESSAGES globusrun-ws -submit -f test.xml
Submitting job...Failed.
globusrun-ws: Error submitting job
globus_soap_message_module: Deserialization of
{http://www.w3.org/2001/XMLSchema}dateTime failed.
globus_soap_message_module: Deserialization of
{http://www.globus.org/namespaces/2004/10/gram/job}NewTerminationTime failed.
globus_soap_message_module: Failed deserialization of content
"2005-05-14T01:18:10.000Z" {http://www.w3.org/2001/XMLSchema}dateTime type.
$
------- Comment #3 From 2005-05-13 18:08:06 -------
Strange. Try using the -dbg command line option.

joe
------- Comment #4 From 2005-05-15 19:08:07 -------
$ globusrun-ws -dbg -submit -f test.xml
Submitting job...
=== REQUEST MESSAGE (length 2088) (time 1116201920.663335000) ===
<ns1:Envelope
xmlns:ns1="http://schemas.xmlsoap.org/soap/envelope/"><ns1:Header></ns1:Header><ns2:Body

xmlns:ns2="http://schemas.xmlsoap.org/soap/envelope/"><ns3:createManagedJob
xmlns:ns3="http://www.globu
s.org/namespaces/2004/10/gram/job"
xmlns:ns4="http://docs.oasis-open.org/wsn/2004/06/wsn-WS-BaseNotific
ation-1.2-draft-01.xsd"
xmlns="http://www.globus.org/namespaces/2004/10/gram/job"><ns3:InitialTerminati
onTime>2005-05-17T00:05:19Z</ns3:InitialTerminationTime><ns3:JobID>uuid:30e39f94-c59e-11d9-9af8-0100000
061b7</ns3:JobID><ns4:Subscribe><ns4:ConsumerReference
xmlns:ns5="http://schemas.xmlsoap.org/ws/2004/03
/addressing"><ns5:Address>https://vppch29.chk.pst.fujitsu.com:51004/wsrf/services/NotificationConsumerS
ervice</ns5:Address><ns5:ReferenceProperties><ns8:ResourceID
xmlns:ns6="http://www.w3.org/2001/XMLSchem
a-instance" xmlns:ns7="http://www.w3.org/2001/XMLSchema"
xmlns:ns8="http://www.globus.org/docs.oasis-op
en.org/wsn/2004/06/wsn-WS-BaseNotification-1.2-draft-01.wsdl"
ns6:type="ns7:string">30e727c2-c59e-11d9-
9af8-0100000061b7</ns8:ResourceID></ns5:ReferenceProperties></ns4:ConsumerReference><ns4:TopicExpressio
n xmlns:ns9="http://www.globus.org/namespaces/2004/10/gram/job/types"
Dialect="http://docs.oasis-open.o
rg/wsn/2004/06/TopicExpression/Simple">ns9:state</ns4:TopicExpression><ns4:UseNotify>true</ns4:UseNotif
y></ns4:Subscribe><ns10:job
xmlns:ns10="http://www.globus.org/namespaces/2004/10/gram/job/description">
<ns10:factoryEndpoint
xmlns:ns5="http://schemas.xmlsoap.org/ws/2004/03/addressing"><ns5:Address>https:/
/localhost:8443/wsrf/services/ManagedJobFactoryService</ns5:Address><ns5:ReferenceProperties><ns3:Resou
rceID xmlns:ns6="http://www.w3.org/2001/XMLSchema-instance"
xmlns:ns7="http://www.w3.org/2001/XMLSchema
"
ns6:type="ns7:string">Fork</ns3:ResourceID></ns5:ReferenceProperties></ns10:factoryEndpoint><ns10:exe
cutable>/bin/echo</ns10:executable><ns10:argument>Hello
World</ns10:argument><ns10:stdout>stdout</ns10:
stdout><ns10:stderr>stderr</ns10:stderr><ns10:queue>kawa_q</ns10:queue></ns10:job></ns3:createManagedJo
b></ns2:Body></ns1:Envelope>
----------------------------------------------

=== RESPONSE MESSAGE (length 2009) (time 1116201922.271148000) ===
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:xsd="http://www.w3.or
g/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:wsa="http://schemas.xmlso
ap.org/ws/2004/03/addressing"><soapenv:Header><wsa:MessageID
soapenv:mustUnderstand="0">uuid:322ced10-c
59e-11d9-9d60-89566777c714</wsa:MessageID><wsa:To
soapenv:mustUnderstand="0">http://schemas.xmlsoap.org
/ws/2004/03/addressing/role/anonymous</wsa:To><wsa:Action
soapenv:mustUnderstand="0">http://www.globus.
org/namespaces/2004/10/gram/job/ManagedJobFactoryPortType/createManagedJobResponse</wsa:Action><wsa:Fro
m soapenv:mustUnderstand="0"
xmlns:ns12="http://www.globus.org/namespaces/2004/10/gram/job"><wsa:Addres
s>https://localhost:8443/wsrf/services/ManagedJobFactoryService</wsa:Address><wsa:ReferenceProperties><
ns12:ResourceID
xmlns:ns12="http://www.globus.org/namespaces/2004/10/gram/job">Fork</ns12:ResourceID></
wsa:ReferenceProperties></wsa:From><wsa:RelatesTo RelationshipType="wsa:Reply"
soapenv:mustUnderstand="
0">uuid:314a6242-c59e-11d9-9af8-0100000061b7</wsa:RelatesTo></soapenv:Header><soapenv:Body><createManag
edJobResponse
xmlns="http://www.globus.org/namespaces/2004/10/gram/job"><NewTerminationTime>2005-05-17T
00:05:19.000Z</NewTerminationTime><CurrentTime>2005-05-16T00:05:20.793Z</CurrentTime><managedJobEndpoin
t><wsa:Address>https://10.90.135.211:8443/wsrf/services/ManagedExecutableJobService</wsa:Address><wsa:R
eferenceProperties><ResourceID>30e39f94-c59e-11d9-9af8-0100000061b7</ResourceID></wsa:ReferenceProperti
es><wsa:ReferenceParameters/></managedJobEndpoint><subscriptionEndpoint><wsa:Address>https://10.90.135.
211:8443/wsrf/services/SubscriptionManagerService</wsa:Address><wsa:ReferenceProperties><ns1:Subscripti
onKey
xmlns:ns1="http://www.globus.org/namespaces/2004/06/core">31fa9270-c59e-11d9-9d60-89566777c714</n
s1:SubscriptionKey></wsa:ReferenceProperties><wsa:ReferenceParameters/></subscriptionEndpoint></createM
anagedJobResponse></soapenv:Body></soapenv:Envelope>
----------------------------------------------
Failed.
globusrun-ws: Error submitting job
globus_soap_message_module: Deserialization of
{http://www.w3.org/2001/XMLSchema}dateTime failed.
globus_soap_message_module: Deserialization of
{http://www.globus.org/namespaces/2004/10/gram/job}NewTe
rminationTime failed.
globus_soap_message_module: Failed deserialization of content
"2005-05-17T00:05:19.000Z" {http://www.w3
.org/2001/XMLSchema}dateTime type.
$
------- Comment #5 From 2005-06-16 02:58:02 -------
I ascertained the cause of the error.
It should consider portability as follows. 


*** source-trees/libxml2/include/libxml/schemasInternals.h.org  Thu Jun 16
16:37:23 2005
--- source-trees/libxml2/include/libxml/schemasInternals.h      Thu Jun  9
19:06:18 2005
***************
*** 138,144 ****
      unsigned int      min     :6;     /* 0 <=  min    <= 59   */
      double            sec;
      unsigned int      tz_flag :1;     /* is tzo explicitely set? */
!     int               tzo     :11;    /* -1440 <= tzo <= 1440 */
  };
  
  /* Duration value */
--- 138,144 ----
      unsigned int      min     :6;     /* 0 <=  min    <= 59   */
      double            sec;
      unsigned int      tz_flag :1;     /* is tzo explicitely set? */
!     signed   int      tzo     :11;    /* -1440 <= tzo <= 1440 */
  };
  
  /* Duration value */
------- Comment #6 From 2005-06-16 15:57:40 -------
Thanks for tracking this down. The patch is committed to CVS and will be part
of
the 4.0.1 update release soon.

joe