Bug 3259 - cas commnads parsing error with CAS_SERVER_IDENTITY variable.
: cas commnads parsing error with CAS_SERVER_IDENTITY variable.
Status: RESOLVED FIXED
: Java WS Core
globus_wsrf_core
: unspecified
: PC Linux
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-05-03 04:48 by
Modified: 2005-09-17 22:35 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-05-03 04:48:51
on RC1 + latest ws-cas from cvs


The $CAS_SERVER_IDENTITY is set with following value:
 
 echo $CAS_SERVER_IDENTITY

/O=Grid/OU=GlobusTest/OU=simpleCA-
lnxwsrf2.boeblingen.de.ibm.com/CN=cas/lnxwsrf2.boeblingen.de.ibm.com

But when running commnads, I get the following exceptions:
1.cas-whoami -debug
getting instance URL
Instance URL not set using -c
Instance URL is https://127.0.0.1:8443/wsrf/services/CASService
getting server identity
Server identity not set using -s
Server identity is /O
CAS client to return the CAS nickname of  client.
Number optional args 1
checkParameters 1
args.length 1
Using identity authorization
Getting reference to cas port
org.ietf.jgss.GSSException, major code: 3, minor code: 0
        major string: Invalid name
        minor string: None [Caused by: Bad name, '=' missing in : /O]


2. cas-list-object -debug user
getting instance URL
Instance URL not set using -c
Instance URL is https://127.0.0.1:8443/wsrf/services/CASService
getting server identity
Server identity not set using -s
Server identity is /O
CAS client to return a list of CAS objects.
Number optional args 1
checkParameters 2
args.length 2
Using identity authorization
Getting reference to cas port
org.ietf.jgss.GSSException, major code: 3, minor code: 0
        major string: Invalid name
        minor string: None [Caused by: Bad name, '=' missing in : /O]



The same commnads pass if the value is specified in -s .
------- Comment #1 From 2005-05-16 14:10:25 -------
*** Bug 3357 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2005-07-18 16:26:26 -------
Issue is with core scripts on unix platform parsing the DEF_OPTIONS bses on 
presence of "=". If the value is enclosed in quotes and has equal to, it needs 
to be treated a whole. No issues on windows platform. Reassigning to core folks.
------- Comment #3 From 2005-09-17 22:35:23 -------
I fixed up the core's template scripts and updated the ws-cas post-deployment 
script appropriately. Now if multiple options are passed via the 
default.jvm.options property they should be separated by ${DELIM} - for 
Unix/Linux scripts only.
The fixes were committed to globus_4_0_branch and trunk.