Bug 3225 - build problem+ java rls client always returns invalid handle
: build problem+ java rls client always returns invalid handle
Status: RESOLVED DUPLICATE of bug 3016
: Replica Location
RLS
: development
: Other Linux
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-04-25 15:03 by
Modified: 2005-04-26 17:24 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-04-25 15:03:50
building on a x86_64 bit (opteron)
using JDK1.5.0 
fedora core 2 
trying to manually build the rls client currently in gt3.9.5

The package will not build on its own. The problem is 

/usr/local/jdk1.5.0//bin/javah -o RLSClient.h -classpath rls.jar
org/globus/replica/rls/RLSClient
javadoc: error - Illegal package name: "org/globus/replica/rls/RLSClient"
1 error

I get around this by manually doing :
/usr/local/jdk1.5.0//bin/javah -o RLSClient.h -classpath rls.jar
org.globus.replica.rls.RLSClient

The build then can be completed. The c client does fine but the java one always
throws an Exception: Invalid handle
------- Comment #1 From 2005-04-26 17:24:25 -------
Thanks. This one happens to be fixed already in CVS and will appear in the 4.0 
release.

*** This bug has been marked as a duplicate of 3016 ***