Bug 3174 - globusrun-ws -debug gives seg fault on sles9 x86_64
: globusrun-ws -debug gives seg fault on sles9 x86_64
Status: RESOLVED FIXED
: GRAM
wsrf gram clients
: development
: PC Linux
: P3 normal
: 4.0.1
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-04-14 16:56 by
Modified: 2005-04-27 10:01 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-04-14 16:56:59
(gdb) set env LD_PRELOAD=/tmp/efence/libefence.so.0.0
(gdb) set file globusrun-ws
No symbol table is loaded.  Use the "file" command.
(gdb) file globusrun-ws
Reading symbols from /opt/gt4/bin/globusrun-ws...done.
Using host libthread_db library "/lib64/tls/libthread_db.so.1".
(gdb) cd condor
Working directory /home/delaitt/condor.
(gdb) cd hello_pvm2
Working directory /home/delaitt/condor/hello_pvm2.
(gdb) set args -debug -submit -Ft Fork -f test-fork.xml
(gdb) run
Starting program: /opt/gt4/bin/globusrun-ws -debug -submit -Ft Fork -f test-
fork.xml
[Thread debugging using libthread_db enabled]
[New Thread 182975480032 (LWP 5469)]
Submitting job...
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 182975480032 (LWP 5469)]
0x0000002a99d50ae1 in memcpy () from /lib64/tls/libc.so.6
(gdb) where
#0  0x0000002a99d50ae1 in memcpy () from /lib64/tls/libc.so.6
#1  0xa3a28fe6a3a28fbc in ?? ()
#2  0x0000002a9ba0b6a7 in globus_l_xio_buffer_cntl 
(driver_specific_handle=0x2a9ead2f98, cmd=10, ap=0x7fbfffcd70)
    at globus_xio_buffer.c:1015
#3  0x0000002a98211fea in globus_i_xio_driver_handle_cntl 
(context=0x2a9e9f5ea8, start_ndx=0, driver=0x2a9b9e3f50, cmd=10, 
    ap=0x7fbfffcd70) at globus_xio_driver.c:1522
#4  0x0000002a98209d20 in globus_xio_handle_cntl (handle=0x2a9ea01f48, 
driver=0x2a9b9e3f50, cmd=10) at globus_xio_handle.c:2651
#5  0x0000002a97e3342e in globus_soap_message_get_marked_buffers 
(handle=0x2a9e85ed60, begin_marker=0x0, end_marker=0x0, 
    out_buffer=0x7fbfffd000, out_length=0x7fbfffcffc) at 
globus_soap_message_handle.c:786
#6  0x0000002a9e43b1b4 in globus_handler_debug_request_invoke 
(session=0x2aa3bfafd0, message_handle=0x2a9e85ed60, result=0)
    at globus_handler_debug.c:18
#7  0x0000002a97e3ee3c in globus_l_handler_callback_call_next 
(args=0x2aa3bfafd0) at globus_handler_chain.c:485
#8  0x0000002a9922b5f7 in globus_callback_space_poll (timestop=0x523d60, 
space=-2) at globus_callback_nothreads.c:1413
#9  0x0000002a960aa293 in ManagedJobFactoryPortType_createManagedJob 
(handle=0x2a9e7f5fe8, 
    
endpoint=0x2a9e77efc0 "https://localhost:8443/wsrf/services/ManagedJobFactorySe
rvice", createManagedJob=0x7fbfffd840, 
    createManagedJobResponse=0x7fbfffd250, fault_type=0x7fbfffd24c, 
fault=0x7fbfffd238) at ManagedJobFactoryService_client.c:5742
#10 0x0000002a960aa15a in ManagedJobFactoryPortType_createManagedJob_epr 
(handle=0x2a9e7f5fe8, epr=0x2a9e77afc0, 
    createManagedJob=0x7fbfffd840, createManagedJobResponse=0x7fbfffd250, 
fault_type=0x7fbfffd24c, fault=0x7fbfffd238)
    at ManagedJobFactoryService_client.c:5693
#11 0x000000000040af3f in globus_i_submit (info=0x7fbfffd970, 
subscribe=0x7fbfffd788, subscribe_epr=0x7fbfffd800, 
    input=0x7fbfffd840, job_epr=0x7fbfffd9f8) at globus_i_submit.c:690
#12 0x00000000004144c6 in main (argc=7, argv=0x7fbfffdbe8) at 
globusrun_ws.c:483
(gdb)
------- Comment #1 From 2005-04-27 10:00:21 -------
*** Bug 3236 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2005-04-27 10:01:12 -------
Fix committed to trunk (the patch from bug #3236).