Bug 3075 - Issues with globusrun-ws and -Sf option
: Issues with globusrun-ws and -Sf option
Status: RESOLVED FIXED
: GRAM
wsrf gram clients
: 3.9.5
: Other Linux
: P2 normal
: 4.0.1
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-04-05 07:42 by
Modified: 2005-08-03 17:19 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-04-05 07:42:51
In S390/Linux,
The container is started with "containercert & containerkey" .

The job submission with file staging using -S worked as follows.
./bin/globusrun-ws -submit -f test_staging.xml -S
Delegating user credentials...Done.
Submitting job...Done.
Job ID: uuid:1989b6d8-a5ca-11d9-a0f3-00025589a5dd
Termination time: 04/06/2005 11:59 GMT
Current job state: StageIn
Current job state: Active
Current job state: StageOut
Current job state: CleanUp
Current job state: Done
Destroying job...Done.
Cleaning up any delegated credentials...Done.

I have created delegated credentials as follows:

/bin/globus-credential-delegate mycred
Arguments: 127.0.0.1 8443 43200 false
Delegated credential EPR:
Address: https://127.0.0.1:8443/wsrf/services/DelegationService
Reference property[0]:
<ns1:DelegationKey 
xmlns:ns1="http://www.globus.org/08/2004/delegationService">4ed5c6b0-a5ca-11d9-
a2d7-a4d8d26e19f3</ns1:DelegationKey>

Using the mycred file with -Sf option , I did the following and got the 
exception.

./bin/globusrun-ws -submit -f test_staging.xml -Sf mycred
Submitting job...Done.
Job ID: uuid:63668ac4-a5ca-11d9-908d-00025589a5dd
Termination time: 04/06/2005 12:01 GMT
Current job state: StageIn
Current job state: Failed
Destroying job...Done.
globusrun-ws: Job failed: Staging error for RSL element fileStageIn.
java.lang.RuntimeException: Couldn't obtain a delegated credential.
        at 
org.globus.exec.service.job.ManagedJobResourceImpl.getStagingCredential
(ManagedJobResourceImpl.java:450)
        at 
org.globus.exec.service.exec.ManagedExecutableJobResource.setStagingStubSecurit
y(ManagedExecutableJobResource.java:1447)
        at org.globus.exec.service.exec.StateMachine.submitStagingRequest
(StateMachine.java:2299)
        at org.globus.exec.service.exec.StateMachine.processStageInState
(StateMachine.java:724)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke
(NativeMethodAccessorImpl.java(Compiled Code))
        at sun.reflect.NativeMethodAccessorImpl.invoke
(NativeMethodAccessorImpl.java(Compiled Code))
        at sun.reflect.DelegatingMethodAccessorImpl.invoke
(DelegatingMethodAccessorImpl.java(Compiled Code))
        at java.lang.reflect.Method.invoke(Method.java(Compiled Code))
        at org.globus.exec.service.exec.StateMachine.processState
(StateMachine.java:334)
        at org.globus.exec.service.exec.RunQueue.run(RunQueue.java:141)
Caused by: 
org.globus.delegation.DelegationException: "/O=Grid/OU=GlobusTest/OU=simpleCA-
gargya2.boeblingen.de.ibm.com/CN=host/lnxwsrf4.boeblingen.de.ibm.com" is not 
authorized to access this resource
        at org.globus.delegation.service.DelegationResource.authorize
(DelegationResource.java:387)
        at org.globus.delegation.service.DelegationResource.authorize
(DelegationResource.java:350)
        at org.globus.delegation.service.DelegationResource.addRefreshListener
(DelegationResource.java:196)
        at org.globus.delegation.DelegationUtil.registerDelegationListener
(DelegationUtil.java:168)
        at 
org.globus.exec.service.utils.DelegatedCredential.getDelegatedCredential
(DelegatedCredential.java:173)
        at 
org.globus.exec.service.utils.DelegatedCredential.getDelegatedCredential
(DelegatedCredential.java:74)
        at 
org.globus.exec.service.job.ManagedJobResourceImpl.getStagingCredential
(ManagedJobResourceImpl.java:442)
        ... 10 more
------- Comment #1 From 2005-04-18 10:41:23 -------
This has been tested and works in CVS and will be in the 4.0.0 release.  So
either wait for the 4.0.0 
release or grab the latest version from CVS.