Bug 3005 - Extra slashes stops PBS from mapping output files
: Extra slashes stops PBS from mapping output files
Status: RESOLVED FIXED
: GRAM
wsrf managed execution job service
: unspecified
: PC Linux
: P2 normal
: 4.2
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-03-24 10:33 by
Modified: 2005-07-28 17:08 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-03-24 10:33:45
PBS has its own filemapping for mapping directories from worker nodes to head
node. Example:

$usecp          viz-login-int:/nfs/home /nfs/home
$usecp          *.isi.edu:/nfs/home /nfs/home


PBS fails to do this mapping if the job description has extra slashes:

#! /bin/sh
# PBS batch job script built by Globus job manager
#
#PBS -S /bin/sh
#PBS -m n
#PBS -o //nfs/home/rynge/job_8f415210-9444-11d9-8cd4-cbc76d304c2b//out.90
#PBS -e //nfs/home/rynge/job_8f415210-9444-11d9-8cd4-cbc76d304c2b//err.90


These extra slashes usually comes from using ${GLOBUS_SCRATCH_DIR} in the RSL
(for example, like Condor does).

Because the output files can't be mapped, they can't be transferred back to the
head node and the job fails.
------- Comment #1 From 2005-04-04 11:39:00 -------
Reassigning to Mats for verification that this is still an issue.
------- Comment #2 From 2005-06-27 15:51:46 -------
This problem still exists in globus_4_0_branch. This is part of the submit file
written out by GRAM:

#! /bin/sh
# PBS batch job script built by Globus job manager
#
#PBS -S /bin/sh
#PBS -m n
#PBS -o //nfs/home/rynge/00d255b8-e74d-11d9-96e1-0008744f939a.0.stdout
#PBS -e //nfs/home/rynge/00d255b8-e74d-11d9-96e1-0008744f939a.0.stderr
#PBS -l nodes=1


Reassigning to Peter.
------- Comment #3 From 2005-07-28 17:08:05 -------
I don't see this happening anymore using the current code in globus_4_0_branch
or the trunk.  Feel free to reopen the bug if you can show explicitly how to
reproduce it.