Bug 2721 - Staging fails when using legacy proxy
: Staging fails when using legacy proxy
Status: RESOLVED FIXED
: RFT
RFT
: development
: PC Linux
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-02-11 09:36 by
Modified: 2005-04-07 03:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-02-11 09:36:20
From gt4-friends:

It looks like you were correct. When I created a proxy with -old flag
and run the same command that worked otherwise this is what I got:

[slavisa: remus - slavisa (0)]: globusrun-ws -factory
https://remus.dstc.monash.edu.au:8443/wsrf/services/ManagedJobFactoryService
-staging-delegate -submit -f test2.xml
Delegating user credentials...Done.
Submitting job...Done.
Job ID: uuid:43fc1ed2-7af6-11d9-a992-0000e29661d3
Termination time: 02/10/2005 23:56 GMT
Current job state: StageIn
Current job state: Failed
Destroying job...Done.
Cleaning up any delegated credentials...Done.
globusrun-ws: Job failed: Staging error for RSL element fileCleanUp.
AxisFault
 faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.userException
 faultSubcode: 
 faultString: java.io.EOFException
 faultActor: 
 faultNode: 
 faultDetail: 
        {http://xml.apache.org/axis/}stackTrace:java.io.EOFException
        at
org.globus.gsi.gssapi.net.impl.GSIGssInputStream.readHandshakeToken(GSIGssInputStream.java:50)
        at
org.globus.gsi.gssapi.net.impl.GSIGssSocket.readToken(GSIGssSocket.java:54)
        at
org.globus.gsi.gssapi.net.GssSocket.authenticateClient(GssSocket.java:105)
        at org.globus.gsi.gssapi.net.GssSocket.startHandshake(GssSocket.java:135)
        at org.globus.gsi.gssapi.net.GssSocket.getOutputStream(GssSocket.java:155)
        at
org.apache.axis.transport.http.HTTPSender.writeToSocket(HTTPSender.java:406)
        at org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:88)
        at
org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
        at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
        at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
        at org.apache.axis.client.AxisClient.invoke(AxisClient.java:147)
        at org.apache.axis.client.Call.invokeEngine(Call.java:2719)
        at org.apache.axis.client.Call.invoke(Call.java:2702)
        at org.apache.axis.client.Call.invoke(Call.java:2378)
        at org.apache.axis.client.Call.invoke(Call.java:2301)
        at org.apache.axis.client.Call.invoke(Call.java:1758)
        at
org.globus.rft.generated.bindings.ReliableFileTransferFactoryPortTypeSOAPBindingStub.createReliableFileTransfer(ReliableFileTransferFactoryPortTypeSOAPBindingStub.java:864)
        at
org.globus.exec.service.exec.StateMachine.submitStagingRequest(StateMachine.java:1882)
        at
org.globus.exec.service.exec.StateMachine.fileCleanUp(StateMachine.java:1439)
        at
org.globus.exec.service.exec.StateMachine.processFailureFileCleanUpState(StateMachine.java:1492)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:324)
        at
org.globus.exec.service.exec.StateMachine.processState(StateMachine.java:258)
        at org.globus.exec.service.exec.RunQueue.run(RunQueue.java:93)

        {http://xml.apache.org/axis/}hostname:remus.dstc.monash.edu.au

java.io.EOFException
        at org.apache.axis.AxisFault.makeFault(AxisFault.java:101)
        at org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:97)
        at
org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
        at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
        at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
        at org.apache.axis.client.AxisClient.invoke(AxisClient.java:147)
        at org.apache.axis.client.Call.invokeEngine(Call.java:2719)
        at org.apache.axis.client.Call.invoke(Call.java:2702)
        at org.apache.axis.client.Call.invoke(Call.java:2378)
        at org.apache.axis.client.Call.invoke(Call.java:2301)
        at org.apache.axis.client.Call.invoke(Call.java:1758)
        at
org.globus.rft.generated.bindings.ReliableFileTransferFactoryPortTypeSOAPBindingStub.createReliableFileTransfer(ReliableFileTransferFactoryPortTypeSOAPBindingStub.java:864)
        at
org.globus.exec.service.exec.StateMachine.submitStagingRequest(StateMachine.java:1882)
        at
org.globus.exec.service.exec.StateMachine.fileCleanUp(StateMachine.java:1439)
        at
org.globus.exec.service.exec.StateMachine.processFailureFileCleanUpState(StateMachine.java:1492)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:324)
        at
org.globus.exec.service.exec.StateMachine.processState(StateMachine.java:258)
        at org.globus.exec.service.exec.RunQueue.run(RunQueue.java:93)
Caused by: java.io.EOFException
        at
org.globus.gsi.gssapi.net.impl.GSIGssInputStream.readHandshakeToken(GSIGssInputStream.java:50)
        at
org.globus.gsi.gssapi.net.impl.GSIGssSocket.readToken(GSIGssSocket.java:54)
        at
org.globus.gsi.gssapi.net.GssSocket.authenticateClient(GssSocket.java:105)
        at org.globus.gsi.gssapi.net.GssSocket.startHandshake(GssSocket.java:135)
        at org.globus.gsi.gssapi.net.GssSocket.getOutputStream(GssSocket.java:155)
        at
org.apache.axis.transport.http.HTTPSender.writeToSocket(HTTPSender.java:406)
        at org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:88)
        ... 19 more
------- Comment #1 From 2005-02-11 10:51:23 -------
I don't know what the GRAM code is supposed to do about this.  For staging, we
just fetch the cred 
from the DS and use it straight to call RFT.  If there's a problem it's
probably with the delegation 
process.
------- Comment #2 From 2005-02-11 11:09:05 -------
I only put it under gram because it has so far only appeared during job
submission and it is not clear from the report which component is actually
causing the problem. It's certainly not the delegation service itself, so my
best bet is either RFT or the C delegation client API.
------- Comment #3 From 2005-02-24 10:32:50 -------
Can I get container logs for this behaviour ?
------- Comment #4 From 2005-04-06 07:39:49 -------
This is probably a problem with globusrun-ws. I'm working on a patch for that
problem so you may want to wait with looking into that until I commit that.

/Sam
------- Comment #5 From 2005-04-06 12:35:58 -------
Added a fix to globusrun-ws. I think this should fix this issue, but don't have
the full setup to easily verify it.

/Sam
------- Comment #6 From 2005-04-06 16:37:18 -------
It would be great if you can give me directions on how I can test this. I can
test and close the bug
------- Comment #7 From 2005-04-06 16:40:21 -------
Run

grid-proxy-init -old

followed by

globusrun-ws <your favorite staging job>

/Sam
------- Comment #8 From 2005-04-07 03:18:26 -------
verified this is fixed.