Bug 2709 - myproxy internationalization
: myproxy internationalization
Status: RESOLVED WONTFIX
: MyProxy
MyProxy
: other
: All All
: P3 enhancement
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-02-09 07:49 by
Modified: 2011-02-28 09:05 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-02-09 07:49:11
No internationalization implementation can be seen for the command 
myproxy-destroy(GT 3.9.4).

I have checked the source code for myproxy-destroy in 
<installer-path>/contrib/myproxy-1.15/myproxy_destroy.c

Sample code snippet from <installer-path>/contrib/myproxy-
1.15/myproxy_destroy.c in GT 3.9.4 follows:

 printf("MyProxy credential '%s' for user %s was successfully removed.\n",
------- Comment #1 From 2005-03-15 08:19:38 -------
The myproxy package isn't internationalized. (I think we only need one bug for
this.)

I don't have plans at this time to internationalize myproxy.  I'll update this
bug if that changes.

However, I welcome a patch to add this feature.  I'd be interested in a patch
that adds an internal 
internationalization API to myproxy (myproxy_i18n_get_string, etc.) that is
used throughout the 
myproxy code and is implemented in terms of an existing API, such as
globus_i18n 
(globus_common_i18n_get_string), where the globus_i18n calls are localized to
the one myproxy 
module that implements the internal API. That way, we can change the underlying
i18n implementation 
without changing code throughout myproxy.
------- Comment #2 From 2005-03-15 08:39:56 -------
*** Bug 2710 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2005-03-15 08:40:22 -------
*** Bug 2711 has been marked as a duplicate of this bug. ***
------- Comment #4 From 2005-03-15 08:40:38 -------
*** Bug 2712 has been marked as a duplicate of this bug. ***
------- Comment #5 From 2005-03-15 08:40:52 -------
*** Bug 2714 has been marked as a duplicate of this bug. ***
------- Comment #6 From 2005-03-15 08:41:25 -------
*** Bug 2941 has been marked as a duplicate of this bug. ***