Bug 2624 - Multiple job hold states and parameterized release operation
: Multiple job hold states and parameterized release operation
Status: RESOLVED WONTFIX
: GRAM
wsrf managed execution job service
: development
: Macintosh All
: P3 enhancement
: 4.4
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-01-25 15:58 by
Modified: 2012-09-05 11:42 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-01-25 15:58:04
The current implementation of the MJES / job description allow for only setting
one hold state.  Multiple 
hold states should be implemented and then the release() operation should take
an argument for the 
state that is being released.  This will allow a client to control the
execution of any phase of a job.  A 
concrete example is to control the stage in and stage out phases of a job.
------- Comment #1 From 2005-05-18 17:26:02 -------
*** Bug 3232 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2005-11-02 19:43:17 -------
*** Bug 3233 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2005-11-02 19:46:01 -------
After the service is modified, this enhancement should be assigned to Bester so
he can add a parameterized -release option to globusrun-ws.
------- Comment #4 From 2007-09-19 11:37:51 -------
Reassigning to current GRAM developer to close/fix as appropriate.
------- Comment #5 From 2012-09-05 11:42:22 -------
Doing some bugzilla cleanup...  Resolving old GRAM3 and GRAM4 issues that are
no longer relevant since we've moved on to GRAM5.  Also, we're now tracking
issue in jira.  Any new issues should be added here:

http://jira.globus.org/secure/VersionBoard.jspa?selectedProjectId=10363