Bug 2601 - Missing 'sigset' linking error
: Missing 'sigset' linking error
Status: RESOLVED FIXED
: Replica Location
RLS
: development
: Macintosh All
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-01-22 12:55 by
Modified: 2007-06-13 15:02 (History)


Attachments
Build Log (35.18 KB, text/plain)
2005-01-22 13:49, Michael Bletzinger
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-01-22 12:55:26
/usr/bin/gcc -O -fno-common -I/sw/include -DBIND_8_COMPAT -D_REENTRANT -Wall -o
                   
.libs/globus-rls-cli cli.o  -L/Users/globus/install/lib -L/sw/lib ./library/.lib
                  
s/libglobus_rls_client_gcc32pthr.dylib /Users/globus/install/lib/libglobus_io_gc
                  
c32pthr.dylib /Users/globus/install/lib/libglobus_xio_gcc32pthr.dylib /Users/glo
                  
bus/install/lib/libgssapi_error_gcc32pthr.dylib /Users/globus/install/lib/libglo
                  
bus_gss_assist_gcc32pthr.dylib /Users/globus/install/lib/libglobus_gssapi_gsi_gc
                  
c32pthr.dylib /Users/globus/install/lib/libglobus_gsi_proxy_core_gcc32pthr.dylib
                  
 /Users/globus/install/lib/libglobus_gsi_credential_gcc32pthr.dylib /Users/globu
                  
s/install/lib/libglobus_gsi_callback_gcc32pthr.dylib /Users/globus/install/lib/l
                  
ibglobus_oldgaa_gcc32pthr.dylib /Users/globus/install/lib/libglobus_gsi_sysconfi
                  
g_gcc32pthr.dylib /Users/globus/install/lib/libglobus_gsi_cert_utils_gcc32pthr.d
                  
ylib /Users/globus/install/lib/libglobus_openssl_gcc32pthr.dylib /Users/globus/i
                  
nstall/lib/libglobus_openssl_error_gcc32pthr.dylib /Users/globus/install/lib/lib
                  
globus_callout_gcc32pthr.dylib /Users/globus/install/lib/libglobus_proxy_ssl_gcc
                  
32pthr.dylib /Users/globus/install/lib/libglobus_common_gcc32pthr.dylib /Users/g
                  
lobus/install/lib/libssl_gcc32pthr.dylib /Users/globus/install/lib/libcrypto_gcc
                  
32pthr.dylib /Users/globus/install/lib/libltdl_gcc32pthr.dylib -lm -lpthread
ld: Undefined symbols:
_sigset
make[2]: *** [globus-rls-cli] Error 1
make[1]: *** [all-recursive] Error 1
------- Comment #1 From 2005-01-22 13:49:13 -------
Created an attachment (id=488) [details]
Build Log
------- Comment #2 From 2005-01-22 13:50:25 -------
I don't have the time to look into this right now but I wanted to make sure
someone new about this error.
------- Comment #3 From 2005-01-26 14:24:21 -------
I believe another Mac user of RLS is planning to fix this and contribute it. 
I'll need to check on that. Because this is a "Mac" only issue and we don't 
claim Mac OSX support for RLS, I'm going to change the severity 
to "enhancement" -- but we're aware we have potential Mac users that would 
like to see this resolved soon.
------- Comment #4 From 2007-05-20 04:31:46 -------
Here is a patch which replaces sigset() with POSIX sigaction() in cli.c and
server.c:

http://furlan.biz/patches/sigaction.patch

Tested on FreeBSD, should work on every POSIX OS.
------- Comment #5 From 2007-05-23 17:34:43 -------
I have recreated the bug with:
globus-rls-server 4.2
MySQL 5.0.27
MySQL Connector/ODBC 3.51.15

One interesting finding is that the old ODBC driver, MyODBC 3.51.06, seems to
have an auto-reconnect feature enabled by default. When using that driver, the
odbc driver reconnects and the RLS does not experience this bug.
------- Comment #6 From 2007-05-23 17:36:09 -------
Ignore comment #5 from me. That was intended for another bug. Thanks to
bugzilla's "feature" for forwarding a user to the next bug when committing
changes to a record.
------- Comment #7 From 2007-06-13 15:02:05 -------
Committed to trunk and globus_4_0_branch -- in time for GT 4.0.5 release.