Bug 2312 - File deletion fails
: File deletion fails
Status: RESOLVED
: RFT
RFT
: development
: All All
: P3 normal
: ---
Assigned To:
:
:
: 2364
:
  Show dependency treegraph
 
Reported: 2004-11-17 15:12 by
Modified: 2005-03-08 00:59 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-11-17 15:12:00
Trying to do:

    <fileCleanUp>
        <deletion>
            <file>file:///tmp/foo0002.out</file>
        </deletion>
        <deletion>
            <file>file:///tmp/foo0002.err</file>
        </deletion>
    </fileCleanUp>


The files do exist:

rynge@ned-0:~/gt4-testgrid/tests/gram-ned-0-fork-3$ ls -l /tmp/foo0002*
-rw-r--r--  1 rynge rynge  0 Nov 17 13:10 /tmp/foo0002.err-staged
-rw-r--r--  1 rynge rynge 14 Nov 17 13:10 /tmp/foo0002.out-staged



The container says:

[Thread-214] WARN  service.DeleteClient [<init>:88] Subject name is null
[Thread-225] WARN  service.DeleteClient [<init>:88] Subject name is null
[Thread-225] ERROR service.TransferWork [run:620] Terminal transfer errorError
deleting a file
 "{0}" [Caused by: Server refused performing the request. Custom message: Server
refused deleting file (error code 1) [Nested exception message:
 Custom message: Unexpected reply: 500-Command failed : System error in unlink:
No such file or directory
500-A system call failed: No such file or directory
500 End.]]
org.globus.transfer.reliable.service.exception.RftException: Error deleting a file
 "{0}" [Caused by: Server refused performing the request. Custom message: Server
refused deleting file (error code 1) [Nested exception message:
 Custom message: Unexpected reply: 500-Command failed : System error in unlink:
No such file or directory
500-A system call failed: No such file or directory
500 End.]]. Caused by
org.globus.ftp.exception.ServerException: Server refused performing the request.
Custom message: Server refused deleting file (error code 1) [Nes
ted exception message:  Custom message: Unexpected reply: 500-Command failed :
System error in unlink: No such file or directory
500-A system call failed: No such file or directory
500 End.].  Nested exception is
org.globus.ftp.exception.UnexpectedReplyCodeException:  Custom message:
Unexpected reply: 500-Command failed : System error in unlink: No such fi
le or directory
500-A system call failed: No such file or directory
500 End.
        at
org.globus.ftp.vanilla.FTPControlChannel.execute(FTPControlChannel.java:311)
        at org.globus.ftp.FTPClient.deleteFile(FTPClient.java:219)
        at
org.globus.transfer.reliable.service.DeleteClient.delete(DeleteClient.java:146)
        at
org.globus.transfer.reliable.service.TransferWork.run(TransferWork.java:535)
        at
org.globus.wsrf.impl.work.WorkManagerImpl$WorkWrapper.run(WorkManagerImpl.java:342)
        at java.lang.Thread.run(Thread.java:534)
[Thread-228] WARN  service.DeleteClient [<init>:88] Subject name is null



I was trying to fix the "Subject name is null" by providing a subject in
etc/gram-service/jndi-config.xml:

                    <name>
                        stagingSubject
                    </name>
                    <value>
                        /C=US/ST=California/L=Los Angeles/O=University of
Southern California/OU=Information Sciences Institute/CN=host/ned.isi.e
du
                    </value>


However, same error.
------- Comment #1 From 2004-11-17 15:14:13 -------
Also, even though the container says the delete fails, the client finishes with
success:

Submission ID: uuid:69356d90-38dc-11d9-b7fd-ce33869e2c85
WAITING FOR JOB TO FINISH
========== State Notification ==========
Job State: StageIn
========================================
========== State Notification ==========
Job State: Active
========================================
========== State Notification ==========
Job State: StageOut
========================================
========== State Notification ==========
Job State: CleanUp
========================================
========== State Notification ==========
Job State: Done
========================================
Exit Code: 0



The CleanUp stage should have failed, right?
------- Comment #2 From 2004-11-17 15:32:50 -------
This is occuring in RFT.  I'm reassigning it to Ravi.
------- Comment #3 From 2004-11-17 15:37:12 -------
Hmm.. The actual error seems to be  : 
"{0}" [Caused by: Server refused performing the request. Custom message: Server
refused deleting file (error code 1) [Nested exception message:
 Custom message: Unexpected reply: 500-Command failed : System error in unlink:
No such file or directory
500-A system call failed: No such file or directory
500 End.]]

which seems to say that GridFTP server is telling me that the file iam trying to delete does not exist, 
even though when you do a ls it does ..  
------- Comment #4 From 2004-11-29 01:54:43 -------
Is this behaivour consistent ? Can I reproduce it by submitting a simple
staging job to GRAM ?
------- Comment #5 From 2004-11-29 10:34:02 -------
Mats,

What host is your gridftp server running on?  What host is the globus container running on?  Is your 
Gridftp server able to see the file /tmp/foo0002.out?

Bob,

Can you try submitting a similar job to confirm the problem.  Is there a test for fileCleanUp directive in 
the test suite?
------- Comment #6 From 2004-11-29 10:52:33 -------
I'll wait until bug 2364 has been resolved to do further work on this bug.
------- Comment #7 From 2004-12-10 11:56:18 -------
This works in my tests - I commented this out to make sure the files were being
created, then re-ran to make sure they were being deleted.

    <fileCleanUp>
        <deletion>
            <file>file://${GLOBUS_USER_HOME}/stdout</file>
        </deletion>
        <deletion>
            <file>file://${GLOBUS_USER_HOME}/my_echo</file>
        </deletion>
    </fileCleanUp>

------- Comment #8 From 2004-12-10 12:12:14 -------
The files were always deleted, but I always got errors anyways.

Maybe this has been fixed as a result of other recent GRAM/RFT work.
------- Comment #9 From 2005-03-08 00:59:24 -------
This has probably been fixed, as I have not seen those messages for a while.
Closing as incomplete.