Bug 2266 - SEG needs to communicate errors better
: SEG needs to communicate errors better
Status: RESOLVED FIXED
: GRAM
wsrf scheduler interface
: development
: All All
: P1 normal
: 4.0.2
Assigned To:
:
:
: 4159 4229
:
  Show dependency treegraph
 
Reported: 2004-11-11 17:24 by
Modified: 2006-02-28 15:48 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-11-11 17:24:08
If the SEG has errors see bug 2173.  It need to communicate them better, so
that the problem is 
observed.  Like sending the errors on stderr to the JSM so that they can be
logged in log4j.
------- Comment #1 From 2005-11-02 16:56:50 -------
I'm changing this to a normal bug since communicating errors between components
seems like a perfectly reasonable expectation.
------- Comment #2 From 2006-02-28 15:48:55 -------
The error fixes in #4229 and #4159 should allow better error reporting. I've
upgraded a few non-fatal problems (missing files or dirs) to fatal ones so those
should be easier to diagnose as well.