Bug 1845 - globus_mutex_lock fails in gss_acquire_cred procedure
: globus_mutex_lock fails in gss_acquire_cred procedure
Status: RESOLVED WONTFIX
: GSI C
Credentials and Proxies
: unspecified
: PC Windows 2000
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2004-07-22 16:58 by
Modified: 2008-08-11 15:00 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-07-22 16:58:11
Reported by Colin Stolley of Condor

 I believe I've figured out why 
I'm getting those:

globus_mutex_lock() failed; errno 6
globus_mutex_lock() failed; errno 6

errors. The mutex in question, internalMutex, is NULL. It appears that 
it's never getting initialized. It looks like the function that was 
designed to do this is globus_l_thread_activate() (line 51). After 
setting break points on that function, it appears that it never gets 
called. I added a line to globus_mutex_lock that calls 
globus_l_thread_activate() if the mutex pointed to by mut is null. That 
seems to fix the problem, though you might have a better solution.
------- Comment #1 From 2004-07-22 17:41:07 -------
*** Bug 1844 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2007-09-19 11:21:15 -------
Closing this, as we're not working on C GSI on Windows, just java.  Univa's
release plans for windows C GSI are unclear, but don't involve funding/effort
from us.